DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

MSVCP90.DLL was not found

Thank you for responding!

 

I gave up yesterday and started with the minor code adjustments in my scripts for the 2015 version, it doesn't use object based plotting like 2019 so I might be done by the end of the week.  Migration of the scripts to 2018... now 2019 has been delayed multiple times due to the low priority (if it works why fix it...) now it doesn't work, go figure. 

 

Of note to anyone else needing the quickest fix, 2011 to 2015 code still maintains a lot of legacy functionality like 2011 and the code changes are minimal. 

 

I have 3 HP computers with Diadem 2011 running no issues, none of the Lenovo's (2 desktops, one laptop) with windows 10 will run Diadem 2011 ymmv.

0 Kudos
Message 11 of 15
(425 Views)

Some remarks on this one:

 

If files like msvc*,dll are missing this is because of missing Microsoft Visual Studio C runtime dlls.

The number behind is related to the C Runtime Version used to build the product.

 

Some versions are delivered with Windows, some are dropped in newer versions.

 

All of them are available as Download with the name

"Visual C++ 20?? Redistributable Package" or in short words vcredist.

 

The MSVC compiler version 9.0 relates to MSVS 2008.

Which means we have to find vcredist 2008 which leads to

 

https://www.microsoft.com/en-us/download/details.aspx?id=26368

 

Pick the correct bitness which is potentially the x86 version for 32bit  DIAdem and afterwards the error should disappear.

 

Maybe this helps someone in the future who is searching for this kind of issue

Andreas

0 Kudos
Message 12 of 15
(418 Views)

Hi Andreas,

 

Thanks for the good guidance.   It had been so long since I had worked this issue that I forgot the solution.

 

Paul

0 Kudos
Message 13 of 15
(413 Views)

Hello Andreas,

 

This solution did not work for me, I found this as a possible solution before posting here in the forum.  I don't know if the V C++ Redist actually registers the DLL or if the DLL needs to be registered through some other software.  For example, script debugger for Diadem 2015 in win 10 after a certain build level needs the DLL registered by some other microsoft software (the remoted debugger is the software of choice for this action). This is currently the only way to get the debugger to operate within Diadem because installing diadem will not register the debugger DLL. These DLLs are not found while installing Diadem 2010 sp1 with the Redist installed on the PC prior to the installation of Diadem 2010, while Diadem 2010 sp1 installs, the service pack fails on installation due to this MSVCP90.DLL not found.  This at least has been my experience over the last couple of days.  I gave up trying, maybe installing Visual Studio 2008 would register this DLL and the Diadem install would find it, I have not tried this course of action.

 

David 

0 Kudos
Message 14 of 15
(406 Views)

The runtime dll just need to be found by the system.

Because the OS has 32 and 64 bit parts you can not just copy them to a central folder.

What you can do ist

  • Find a folder that contains the dlls.
    When redist is installed they can be found at
    C:\Windows\WinSxS\x86_microsoft.vc90.crt?????
  • Open a cmd shell
  • call
    set PATH=C:\Windows\WinSxS\x86_microsoft.vc90.crt????;%PATH%​
  • run the installer exe from the same cmd batch
  • I would assume that this process should help the installation process to find the dll
0 Kudos
Message 15 of 15
(400 Views)