From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

MSVCP90.DLL was not found



I am trying to install DIAdem 2011 onto my Windows 10 laptop. I am doing this from an NI download as I am working remotely and don't have my disc with me. I already have DIAdem 2010 loaded but don't want to remove this until 2011 is successfully installed.


The installation seems to have been successful, but when I run it I get an error message that says, "The code execution cannot proceed because MSVCP90.DLL was not found. Reinstalling the program may fix this problem." A search of the net produced plenty of results and so I duly followed the advice and installed the Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update (both 32- and 64-bit versions). Unfortunately, this didn't improve things.


I've reinstalled and repaired both the C++ update and DIAdem 2011 installations many times and in different orders, with a restart in between, but nothing seems to help the situation.


Does anyone have any ideas what I can try next?



0 Kudos
Message 1 of 15

Hi Simon,


This is Michael from Technical Support Engineering - we currently have a service request about this exact issue.


We will continue to work on the service request and I will update this forum post with any steps we try in case others run into the same issue.


Kind regards,


0 Kudos
Message 2 of 15

The oldest version of DiAdem supported would be 2015 SP1 for Windows 10.


Suggested solution: Upgrade to a Windows 10 compatible version of DiAdem to guarantee DiAdem installing (per this documentation).

0 Kudos
Message 3 of 15

Hi Mdoherty,

Do you have some Hints und Bytes to solve the Problem without update DiAdem 2011???

Example: copy the missing dll, registry hack, kompatibility mode or anyhing else?






0 Kudos
Message 4 of 15

Hi Wolfgang,


If you have to have DIAdem 2011 then using a Windows XP or Windows 7 Virtual Machine in either Virtual Box or VM Ware, would allow it to work! 

Is that an option for you?



0 Kudos
Message 5 of 15

Hi Pesmith8,

Thanks for your answer...Yes, I know this way but...

Are there no other Options?






0 Kudos
Message 6 of 15

Hello Wolfgang,


I do not have access to older DIAdem version (thanks to NI's restrictive handling of access to older versions on their download page), but have you tried the "Compatibility" settings in Windows 10 yet?


Here's how you get there:


1. Find the executable for DIAdem (in my case something like: "C:\Program Files\National Instruments\DIAdem 2012"


2. Right click on the "diadem.exe" file to bring up the context menu and then select "Properties" on the bottom

3. Select the "Compatibility" tab and see if you can change settings there to make DIAdem run with compatibility settings



I haven't tried this (for lack of access to older versions of DIAdem), but it might be a way to make things work for you and should not take much time to test.


Best regards,




Otmar D. Foehner
0 Kudos
Message 7 of 15

Hello Otmar,

Thanks - but I tried this without success.


Any other ideas?






0 Kudos
Message 8 of 15

Digging up a 2+ year old topic.  I have successfully installed Diadem 2011 on more than one windows 10 installation with no issue.  I am currently having this same issue on a Lenovo Desktop computer.  Was there any solution found for this?  We still have legacy scripts for Diadem 2011 for processes that have not changed.  I am currently installing 2019 and 2011 on our data processing systems that previously worked but needed to be wiped and reinstalled.  Now there is a problem installing with a fresh Win 10 pro installation.  




0 Kudos
Message 9 of 15

Hi David,


I never found a solution I'm afraid. I ended up buying a 2019 licence and updating all our scripts to the latest language.



0 Kudos
Message 10 of 15