DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

Diadem cannot see or access Global Virtual Channels in DAQmx

Highlighted

I have Diadem 2017 SP 1 (Advanced DAC Bundle) 64 bit running on Windows 10 Pro.

 

It won't see or pull through the analogue channels from my cDAQ system. It will still work with the XNET portion so I can see CAN data, but none of my thermocouples or analogue inputs work. It used to work on my older Win 7 machine, but we got new laptops and upgraded to 10 and whilst it worked for a while (ported over the configuration), it suddenly stopped working and I cannot get it back. I tried to build a new configuration from scratch but the same issue persists.

 

When trying to "open" the DAQ block in the DAC builder in Diadem, I can't even open the window. It just hangs. Or if it miraculously does open (after 20+ minutes of waiting) it shows nothing at all, its all empty. 

 

The channels do work. I can see them in NI MAX and I can see both the raw signal from the module and I can run the Virtual Channel in MAX (with the scaling applied) and see the numbers changing. So its all working up to that point. Just not getting through to Diadem. 

 

I think the NI MAX version is pretty recent so I am wondering if there is an older NI MAX version that might work better?

 

Totally lost because I installed everything fresh on another laptop and it still doesn't work.

0 Kudos
Message 1 of 2
(66 Views)
Highlighted

Hi AlexMason,

 

Please can you launch the "NI IO Trace" tool, start the logging, proceed the steps described above and post the log file? We hope to find the answer for the problem with this info.

 

Greetings

Walter

0 Kudos
Message 2 of 2
(3 Views)