DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

DataFinder Server- How to set the priority of DataPlugins with same extension

Highlighted

Hello everybody!

 

This is the scenario: [everything is on local machine]

I'm using the Analysis Server Procedure triggered by a new flow of data in the Data Finder Indexed folder to convert raw data into TDMS data. The raw data are binary data and the extension is .bin, the plugin used is "Plugin A".
In my system, I have other raw binary data but they need a different plugin, called "Plugin B".
DataFinder Server is indexing the folder used ad a trigger using only "Plugin A"

 

Behaviour:

When I contribute with fresh data into the indexed folder, Analysis server Procedure is triggered but it fails, and I receive an error that I created in the Main.vbsa that means that the Analysis Server is using the "Plugin B" instead of "PluginA".

 

Performed tests:

1) If I delete from Diadem the "Plugin B" the behaviour is correct and I can see my data converted properly
2) If I leave the "Plugin B" (because the next step of my application will be converted also .bin file that uses Plugin B) and In DataFinder,  "Manage DataPlugins and filename extensions" I enable only "Plugin A" and, I set (in "File extensions" Tab >> bin setting) the High priority to Plugin A and below Plugin B --> the behaviour remains incorrect.

 

Can someone help me with this issue?
many thanks

0 Kudos
Message 1 of 2
(80 Views)

Hi I-Penny90,

We tried to understand and tried to reproduce the problem, but in our cases, everything worked as expected. – Maybe we didn’t fully understand the issue.

Which versions do you use?

How can you delete a DataPlugin on the DataFinder Server from DIAdem?

Are both DataPlugins looking at the same file extensions?

Are the DataPlugins exact identical on the DataFinder Server and on the DIAdem PC?

Maybe it will help if we can have a look at your ANP files.

 

Greetings

Walter

0 Kudos
Message 2 of 2
(26 Views)