Showing results for 
Search instead for 
Did you mean: 

Closing diadem triggers dialog box "cannot find specified object"

Go to solution

Hi, my colleague has strange problem. He has Diadem 2017 .0.06657 64bit on Win 10.

I open Diadem instance and close it. No problem happens.

But when i open Diadem and i open second instance, after i close the second instance, it triggers this dialog box "Cannot find specified object".

There is no info what triggers it or where i could find the problem. It happens just in the second instance, one instance closes with no error. Can you please help me where i should look for fixing it. 

It throws 6 same windows. After you click OK, it opens directyly the same windows again for 6 times. My program in Diadem uses about 20 people and noone has this strange dialog box.



0 Kudos
Message 1 of 8

Never seen something like this before.


I would start in the "UserCmd"s

Setting -> Extension -> User Commands


Are some of them added?

The Class_Terminate method of objects created there will be called wehn DIAdem is shut down.

Is there some interfer in the Code that was added?

0 Kudos
Message 2 of 8


we got one script included in UserCommands and there were 2 classes with Class_Terminate methods really. So i deleted them, firstly just commented the methods, but no difference. Its not on my computer but i remotly connect to it, so i tried with closing Diadem, so i didnt try hard reset of the computer, but it should refresh by just closing and starting Diadem.


ONE IMPORTANT NOTE i didnt mention is that it happens only on the non first instance of Diadem. If i start Diadem and close it, there is no error triggered. But if i start Diadem and opens more multiple Diadems and after closing them triggers the error, the first Diadem looks clean and doent trigger error. This is really weird and im nervous from it cause i dont have control upon it if u get me Smiley Happy

0 Kudos
Message 3 of 8

Does it disapear if you remove the UserCommand?

0 Kudos
Message 4 of 8

It still triggers, I deleted the UserCommands, saved the settings, closed Diadem. 

-started Diadem

-started second Diadem

-closed second Diadem and error triggers. 

I saved the screen to file im adding as attachement.

Please help Smiley Happy

0 Kudos
Message 5 of 8
Accepted by topic author Lukas_Doubek
04-24-2019 11:52 PM

In folder "C:\Users\<USER>\AppData\Local\National Instruments" i renamed all folder which system allowed me to rename (Diadem, UserAccount), after started Diadem, it created new folders and problem dont appear no more, so its solved. If in future someone report same problem, u got solution now Smiley Happy

0 Kudos
Message 6 of 8

Would it be possible to share the Desktop.ddd file of the folder to have a look?

0 Kudos
Message 7 of 8

Ok, here you have it


// due to attachement rules you have, i renamed it to *.txt

0 Kudos
Message 8 of 8