DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

BarSource.VBC error

Dear all,

when I want to open any DAC block and place it in to the workspace following error message appears.

Did anybody same experience and could help me please?

With regards

Milos








IMG_20211012_223714.jpg

0 Kudos
Message 1 of 4
(496 Views)

Hello Milos,

 

We are aware of a problem with certain device driver blocks in DIAdem 2021 which will be fixed in the service pack (coming soon). But having such problems with any block is unknown.

Which DIAdem version do you use?

 

You can try to run DIAdem with the default configuration and check whether this helps.

 

Please follow the steps below:

 

Close DIAdem

Go to the folder c:\Users\<Name>\AppData\Local\National Instruments\DIAdem\ and rename the DIAdem desktop folder (the version number) like “2021” to “_2021”

Launch DIAdem

 

Hopefully this helps.

 

Greetings

Walter

0 Kudos
Message 2 of 4
(466 Views)

Hello Walter,

thank you for your response. Recommended solution helps but only partially - at a minimum, it acts as a safe entry point for function recovery. After editing the directory, I can freely use DAC blocks except the only one, which is the OPC block. Unfortunately, this is the most important thing I need for my work. After editing the directory, I can freely use DAC blocks except the only one, which is the OPC block, the opening of which will always cause the specified error. Unfortunately, this is the most important thing I need for my work.

I work with the OPC server from the company Software Toolbox even in the older version of DIAdem 2011 and there has never been any problem of working with DAC blocks or communication. Everything could be set up comfortably.
In the end, I found a solution to work around this peculiarity in version 2021, and I send screenshots to this. It is interesting that I can work with this comfortably without any error, but clicking on the original NI block for OPC always means same failure mode and using the solution described by you to correct DIAdem to the initial conditions.

 

Regards 

Milos

0 Kudos
Message 3 of 4
(429 Views)

Hello Milos,

 

Thank you for your update.

Yes, the OPC device driver block in DIAdem 2021 is the one with problems. We have fixed this for the DIAdem 2021 SP1 which comes end of October (I assume on 22.10.2021).

 

Greetings

Walter

0 Kudos
Message 4 of 4
(426 Views)