DATA AHEAD toolkit support Blog

Community Browser
Showing results for 
Search instead for 
Did you mean: 

Third-party Toolkit Activation not possible on LabVIEW 2017 64-bit

Active Participant

The title of this entry should explain it well enough:

There exists a very very annoying bug in LabVIEW 2017 64-bit: You cannot activate a third-party toolkit in this particular LabVIEW version. This has come up several times now with our customers and I'm getting tired of always answering the same. So I'm writing this article and in the future, I just can send a link.


So again:

You will not be able to activate a third-party toolkit like XLR8, SP7 or git4G in LabVIEW 2017 64-bit.


What is the solution?

Do not use this LabVIEW version. Either stick to the 32-bit version of LabVIEW 2017 or since February 2018 if you need the 64-bit version stick to LabVIEW 2017 SP1 64-bit.

If you still experience problems with LabVIEW 2017 SP1 64-bit (I once has those during tests in a virtual machine), it seems that the additional installation of LabVIEW 2016 64-bit can resolve the activation problems.


For further general hints read this article from NI's support forum.


Data Ahead

Kudos are welcome...