DASYLab

cancel
Showing results for 
Search instead for 
Did you mean: 

RS232 communication - tie RTS down

Solved!
Go to solution
Highlighted

Hello there,

 

Weird problem...

 

I'm working with a special RS232 device that needs to have the RTS pin tied down (without any handshake !).

 

I made some experiments with the terminal software Realterm, it works fine, only if the RTS is tied down.

 

Is there a way to set the RTS value somewhere in the Dasylab sheet ?

 

Thanks in advance !

0 Kudos
Message 1 of 3
(219 Views)
Highlighted
Solution
Accepted by topic author Yoruk

Nothing weird about that. Not much is standard with RS232 devices except that they operate on the serial protocols at the low level. 

DASYLab has three options of the handshake, including tying one or both of RTS and DTR down.

 

I usually suggest that you try each setting in turn, but I think that you need the second one, Without (R1/D0)

 

Snag_430bf89.png

 

 

- cj

Measurement Computing (MCC) has free technical support. Visit www.mccdaq.com and click on the "Support" tab for all support options, including DASYLab.
0 Kudos
Message 2 of 3
(205 Views)
Highlighted

Thanks for your quick feedback ! I'll try this and let you know ! 😀

0 Kudos
Message 3 of 3
(193 Views)