DASYLab

cancel
Showing results for 
Search instead for 
Did you mean: 

2020_1 Read channel offset

Hello,

 

I try read asc file where is 20 channel to Dasylab 2020.1 but when I try to add number 16 to channel offset in read module no 2 it will change 16 to value -5.

 

Can someone help with this?

 

MYMTEST_0-1610876644878.png

 

0 Kudos
Message 1 of 6
(270 Views)

Please post a sample file with the same type of header and number of channels. 

I'll take a look at it and see if I can help. 

 

You may want to contact your DASYLab reseller directly, especially if it is a problem unique to the DASYLab 2020.1 service pack update. 

--cj --DASYLab Pro -- Retired
0 Kudos
Message 2 of 6
(206 Views)

Hi,

 

Yes I got instructions for this from support (mcc). Apparently these new feature smartmux (this just my conclusion) causes that read -module is more accurate form of this ascii-file. Older version (2016SP2) works fine.

 

Luckily I found that kind of editor which can open andd edit those big ascii-files.

 

Attached shorter version of my ascii-file, if you also want to look that. This is exported from  EVIDAS (HBM or now HBK data acquisition soft.). I am not sure is there any settings for ascii files.

 

Another issue came up when I write csv file, I have to choose semicolon that data is in columns when I opened file with excel. Is this depend on setting of my operating systems?

 

Br Mika

0 Kudos
Message 3 of 6
(200 Views)

I see the problem. I hope that support (mcc) has reported it. 

 

With regard to CSV. When you create the file and select CSV as the file extension, then DASYLab will use the regional settings to configure the data separator. 

 

In most of Europe, the decimal separator is a comma, so a "comma separated values" file would not be able to use comma as the data separator. Excel recognizes the semicolon ( ; ) as the default data separator for CSV. That's one reason that DASYLab did not support CSV files for so many years. 

 

When you create the file, you can specify the data separator and decimal separator. 

 

With DASYLab 2020, the Read Data module also allows you to specify how the file is configured. I was able to easily override my regional settings (US, decimal is dot, CSV is comma) to read the file ...

 

But, as you say, you cannot read the upper channels. 

--cj --DASYLab Pro -- Retired
0 Kudos
Message 4 of 6
(190 Views)

Hello
We see the problem and can also reproduce the error.
The problem here is that with DASYLab 2020 some additional plausibility tests have been added in the dialog, but with the given file they do not have the desired result. DASYLab always looks for a line with the number of channels in the file.
However, this is not present here, so the offset is calculated incorrectly.
For a work arround you can write the number of channels in the text file by inserting the following line as the second line:
Number of channels : 20
Then the number of channels is recognized and the offset is no longer incorrectly adjusted. With this modification, I was able to read the upper channels too.

 

Stephan

 

measX GmbH
www.measx.com
0 Kudos
Message 5 of 6
(164 Views)

Hello Stephan and CJ,

 

Thank you for your help. Now I know how to handle these files with 2020_1

 

Br Mika

0 Kudos
Message 6 of 6
(145 Views)