Showing results for 
Search instead for 
Did you mean: 

DAQExpress not recognizing NI9209 C-Series voltage input module



I am struggling to get DAQExpress to recognize a NI9209 c-series voltage input module. I have a cDAQ-9171 compactDAQ chassis with the NI9209 in it. I am trying to use DAQExpress to record the analog channels, but I can’t get DAQExpress to “see” the NI9209. It will only show me that the cDAQ-9171 is connected.


I installed DAQExpress 2.1 from the CD that came with the cDAQ-9171. I can get the NI9209 to work if I use the Measurement and Automation Explorer program. Only then am I able to get any response from the device.


I’ve checked your website to no avail, the “Acquire, Record, and Process Data in NI DAQExpress” and other videos in that series do not help as I can't see my device.


Any help you can give me would be greatly appreciated.

0 Kudos
Message 1 of 7

Hi HP1662AS,

Would you mind attaching a screenshot of your DAQExpress layout? Do you see anything there at all? 

Also, it is worth checking to see if your module is supported with that version of DAQExpress. It's possible that maybe the 9209 is not supported in version 2.1? I'm not sure. See if you can find the readme, there should be a list of supported hardware in there. 

0 Kudos
Message 2 of 7



Thanks for the reply. I have just got it working. I had to reinstall the driver for the NI9209 to get it working. It is strange though because it worked in the Measurement and Automation Explorer program, but not DAQExpress.


Thanks again.

0 Kudos
Message 3 of 7

Interesting. Checking the drivers is usually a good idea, glad it worked out for you!

0 Kudos
Message 4 of 7

Well, it seems the saga is not over. The device is no longer working again, and I have tried reinstalling the driver as before to no avail. I'm not sure if restarting the computer, or just restarting the program was the reason. However, I just noticed that the problem seems to be related to the cDAQ-9171 chassis, where a little orange arrow in the corner brings up a warning saying that the driver is not installed (see screenshot attached). I can tell you that I have uninstalled it and reinstalled it and it shows up in device manager as fully functioning. It still also works fine in the Measurement and Automation Explorer (MAE). I am not sure why DAQExpress is unable to use the cDAQ-9171 but the MAE is?

0 Kudos
Message 5 of 7

Hi HP1662AS,


For clarification is this when there is no module in cDAQ-9171, or is this showing up when you have a module attached, such as the 9209 previously mentioned?



Tyler C.
Applications Engineering
National Instruments
0 Kudos
Message 6 of 7

This is when the 9209 is attached to the chassis.

0 Kudos
Message 7 of 7