Continuous Integration

cancel
Showing results for 
Search instead for 
Did you mean: 

NI LabVIEW CLI won't start LabVIEW VI Server fast enough

Solved!
Go to solution

Bas.v.E,

 

What "operations" page are you looking at and what example codes are you asking to have updated?

 

I'm checking on the CLI.  If the component was updated with the LabVIEW 2018 SP1 release, NI will post a new version to NI.com in early January. 

Eric Reffett | Director, Product Management | 1.512.683.8165 | ni.com
0 Kudos
Message 11 of 26
(3,836 Views)

This operation help page:

http://zone.ni.com/reference/en-XX/help/371361R-01/lvconcepts/cli_predefined_operations/ 

 

on the VIAnalyzer section there is a piece of example code where this: 

-ReportSaveType "html"

should be this:

-ReportSaveType "HTML"

0 Kudos
Message 12 of 26
(3,800 Views)

Where is the ini you speak of?

<LV_Version_Path>\labview.ini?

 

no keys are currently there for me in any labview version.

------------------------------------
Jon Kokott
CLA, CLED, CTD, MCP C#
0 Kudos
Message 13 of 26
(3,585 Views)

The Union file is located in 

C:/program files(86)/national instruments/shared/labviewcli/

0 Kudos
Message 14 of 26
(3,579 Views)

This is still a serious problem.  I can not find any combination of timeouts that will allow my Jenkins labview builds to succeed.

 

I am using labview 2019 SP1 on Windows Server 2016

 

I have tried timeouts from 5 - 60 seconds and I almost always get Error Code 350000

 

Any suggestions from the crowd?

0 Kudos
Message 15 of 26
(3,166 Views)

https://github.com/JamesMc86/G-CLI

 

Use this instead. All my similar issues were solved.

0 Kudos
Message 16 of 26
(3,162 Views)

So someone wrote a wrapper to fix this issue instead of NI actually fixing the problem? 

So why do we pay these guys all this money for support then?

0 Kudos
Message 17 of 26
(3,154 Views)

I mean, it's an open source project by an individual who has contributed to the LV community for years. I like that it's an open source solution, we don't need to rely on NI for everything.

 

NI most likely has many other internal projects they are working on. Spending time on a tool that I would guess less than 1% of the community uses doesn't make business sense.

 

G-CLI gets the job done.

0 Kudos
Message 18 of 26
(3,137 Views)

I have talked to some guys from NI some time ago....  the statement was: take James' tool, it seems to work better.

Message 19 of 26
(3,125 Views)

I have used LabVIEW CLI with azdo and Jenkins and have run into this issue in both cases. Sometimes the solutions in the forum do not work, or the timeout is simply too long to deal with. My solution has been to call LabVIEW.exe prior to calling the CLI. For instance, in AzDo I store the version of LabVIEW I am using for my build as a variable $(lvVersion) then use it to call LabVIEW at the location of the LabVIEW executable.

 

steps:
- task: PowerShell@2
  displayName: "Open LabVIEW"
  inputs:
    targetType: 'inline'
    script: Start-process -FilePath "C:\Program Files\National Instruments\LabVIEW $(lvVersion)\LabVIEW.exe"
   Then I call the LabVIEW build spec through the CLI:
  - task: PowerShell@2
    displayName: "Execute LabVIEW Build Spec"
    inputs:
      targetType: 'inline'
      script: LabVIEWPath "C:\Program Files\National Instruments\LabVIEW $(lvVersion)\LabVIEW.exe"
 
Your Mileage May Vary
Michael Bilyk
Former NI Software Engineer (IT)
0 Kudos
Message 20 of 26
(2,878 Views)