Communauté des utilisateurs LabVIEW Discussions

annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 

débutant LABVIEW : acquisition signal analogique + temps

bonjour,

j'ai suivi une formation LABVIEW récemment mais j'ai un peu de mal à entrer dans le vif.

voici une partie de mon problème :

- j'ai inséré une carte d'acquisition dans mon PC (6229) connectée aux borniers CB68LP

- j'acquiers avec une tension analogique (Va1) et 2 tensions numériques (Vn1,Vn2).

Le front descendant de Vn1 initie la boucle à t=0 (10 ou 20 itérations).

Dans cette boucle, les fronts descendants (1024 entre 2 tops de Vn1) de Vn2 donnent les tops d'acquisition de la tension analogique.

Problème, la régularité de Vn2 n'est pas irréprochable et il peut arriver que certains tops disparaissent.

Je veux donc enregistrer dans un tableau 10 (ou 20) *1024 les valeurs de Vn1 et t afin de les traiter ensuite.

Pourriez vous m'aider à concevoir le VI correspondant? Merci d'avance,

Pierre

0 Compliments
Message 1 sur 8
4 322 Visites

je te conseille d'intégrer un filtre à ton signal... s'il y a trop de bruit, il se peut que tu ais des tops de courte durée...

0 Compliments
Message 2 sur 8
2 731 Visites

merci de ta réponse. en fait, non, les tops viennent d'une roue codeuse située sur un moteur tournant à basse fréquence (20Hz) dont la fréquence de rotation n'est pas monotone.

0 Compliments
Message 3 sur 8
2 731 Visites

Tu as bien vérifié les front montant s'ils n'y a pas du bruit... J'ai déja eu le même problème avaec des roues encodeuses.... J'ai ajouter un filtre pour couper les haute fréquence et ça fonctionné pour moi... tout dépend de ton optocoupleur...

0 Compliments
Message 4 sur 8
2 731 Visites

Tu peux envoyer une photo de ton code....

0 Compliments
Message 5 sur 8
2 731 Visites

je suis très débutant : j'essaie de modéliser sur mon PC à quelque distance de la manipe et j'ai encore du mal à entrer les signaux générés par mes GBF.

Je mets les bouts pour qq temps, le fil de discussion reprend la semaine prochaine, merci de tes suggestions.  Sincèrement,

Pierre

0 Compliments
Message 6 sur 8
2 731 Visites

Hello vous deux,

Je pense qu'il faudrait vous rendre sur le forum qui est destiné à répondre à ces questions techniques et qui fourmille d'ingénieurs prêt à vous aider. Ici aussi on a plein de personnes très bien mais le but n'est pas de résoudre des problèmes mais plutôt de partager autour de divers sujets

Voici l'url pour accéder au forum francophone : http://forums.ni.com/t5/Le-forum-francophone/ct-p/FrenchForums

ou au forum international : http://forums.ni.com/

Bon courage !

Marie

Message 7 sur 8
2 731 Visites

merci, je vais suivre votre conseil. Je démarre sur le forum et je me suis trompé d'endroit pour poser ma/mes question-s. Cordialement,

PB

0 Compliments
Message 8 sur 8
2 731 Visites