Certification

cancel
Showing results for 
Search instead for 
Did you mean: 

CLD Prep Sprinkler Practice Test Critique

Hello again to all,

 

This is my first shot at the Sprinkler system CLD practice test; my fourth CLD practice test so far. I would appreciate any constructive feedback on this one. I actually got to this point with about 20 minutes to spare.

 

As before, I've saved it as a LabVIEW 2014 project.

 

Thanks to all for your help.

Dan


0 Kudos
Message 1 of 7
(5,398 Views)

You took the advice on documentation to heart ! EXCELLANT I think you missed only one user indicator. All sub-diagrams have comments, all vi doc is there.  You'ld probably max documentation.

 

Style isn't bad at all  -a couple of wire bends some wire crossings ... BD sizes are a bit too large and not placed on the screen all the way 

 

But, functionality is going to take a few hits:

  1. States.ctl has an unused state! 
  2. Timing FGV.vi has problems
    1. You have "Dead" code.  The error wire is not used in the while loop, it should pass around the loop
    2. you do not stop the timer when time expires elapsed time continues to increment.  If you had made "Advance" a switched boolean you could test the FGV easy with "Run Contineous" and nailed the bugs- Timing is a key concept being tested.
  3. Read csv File.vi looks like it would work except it is broken:  My friend, I'm sorry to tell you your LabVIEW 2014\vi.lib is corrupt 

Capture.PNG

 

Open your copy of file.llb and select View>>Dates they should be 1/25/2015 you should repair your LabVIEW install.

 

Main.vi I can't see all of it running but

  1. If you are running and enter setup mode the sprinklers keep running you only show the controller status as setup mode untill the next timeout event
  2. you have a breakpoint in the start VC event case
  3. Press Stop and the Zone indicators stay in the same state
  4. There is no error handleing  yup need at least  to or the Stop Boolean with the error wire an put a simple error handler on the error SR outside the loop- Error handleing is another large part of what is being tested

You took the rest of our advice well.  I hope you bump up that functionality. Review This Starting on pg3 the guide breaks down the 10 conscept that are tested and details each of them.

 

Good Wishes

 


"Should be" isn't "Is" -Jay
Message 2 of 7
(5,393 Views)

Once again, all good points to consider. Thank you. 

 

I'm not sure how to explain the broken Read csv File.vi. I don't have an install of LV 2014. This was saved as previous version from LV 2015. Any time I open the vi, it opens the Read Delimited Spreadsheet.vi(s) from vi.lib in LV 2015. In other words, I don't see a broken run arrow, and don't know how I could reproduce the problem. Any ideas would be welcomed.

 

On your Main vi points, I will be sure to correct these issues in furure trial runs.

 

Once again, your input is greatly appreciated.

Dan


0 Kudos
Message 3 of 7
(5,383 Views)

I'm not sure how to explain the broken Read csv File.vi. I don't have an install of LV 2014. This was saved as previous version from LV 2015. Any time I open the vi, it opens the Read Delimited Spreadsheet.vi(s) from vi.lib in LV 2015. In other words, I don't see a broken run arrow, and don't know how I could reproduce the problem. Any ideas would be welcomed

 


 

Hmmm.  Bring that over to the LabVIEW forums.  That may be a bug in the mutation durring backsave.  feel free to bring my snip along (Attached) since I have not installed 2015 I cannot investigate this myself.


"Should be" isn't "Is" -Jay
0 Kudos
Message 4 of 7
(5,377 Views)

Is there a specific forum spot for possible bug reports, or would this belong in the general LabVIEW forum?

 

Dan


Message 5 of 7
(5,364 Views)

Dan,

Yes, potiential Bugs are posted to the LabVIEW Forum.  I would start the post myself but I do not have your 2015 source for "Read CSV...vi".  attach both the 2015 source, the 2014 backsave and my png.  reference this thread via link.

 

Then others can try to duplicate what may be a mutation error.  Thanks


"Should be" isn't "Is" -Jay
0 Kudos
Message 6 of 7
(5,360 Views)

@JÞB wrote:

I'm not sure how to explain the broken Read csv File.vi. I don't have an install of LV 2014. This was saved as previous version from LV 2015. Any time I open the vi, it opens the Read Delimited Spreadsheet.vi(s) from vi.lib in LV 2015. In other words, I don't see a broken run arrow, and don't know how I could reproduce the problem. Any ideas would be welcomed

 


 

Hmmm.  Bring that over to the LabVIEW forums.  That may be a bug in the mutation durring backsave.  feel free to bring my snip along (Attached) since I have not installed 2015 I cannot investigate this myself.


I wanted to follow up on this to close the loop.  

 

If you use the new to 2015 "Read/Write Delimited Spreadsheet.vi's" you cannot save for previous without resulting in broken code. Read/Write Delimited Spreadsheet.vi's did not exist before 2015 and, even though the depreciated "Read/Write Spreadsheet.vis" would seem like the correct mutation, the change in functionallity by "Automagically" making the replacement would be hidden to the developer.  There are other reasons but, breaking the code rather than hiding functionality change is a good enough argument for me!


"Should be" isn't "Is" -Jay
0 Kudos
Message 7 of 7
(5,158 Views)