CSLUG - Central South LabVIEW User Group (UK)

Highlighted

Strange UI response

Hi All, 

I have a UI which is acting really strange. I've never seen this before and not sure what is causing it, hoping someone can help!

FP Layout.png

I basically have a system tab control with buttons which I am using as a wizard, the tabs are hidden at runtime. What is happening, at runtime and in development environment, is that the buttons disapear and reappear at random when hovering over with the mouse. Below is a video

 

 

The video was taken in the dev environment, but the same thing happens when built.

Does anyone know what is happening and how I can resolve this?

Thanks, 

Greg

0 Kudos
Message 1 of 11
(182 Views)
10 REPLIES 10

Re: Strange UI response

Can you include a minimal version I can play with LV2018 or lower would be good

I've not seen it before...

0 Kudos
Message 2 of 11
(157 Views)

Re: Strange UI response

Hi Steve, 

Attached is a single vi which has the same behaviour, LV2018SP1. I've removed pretty much all the logic!

Have a look at Step 2, when hovering over the buttons they disappear. I have set up tabbing so when they are tabbed to, they pop back. Very strange indeed!

I haven't tried replacing the buttons with another style but don't see why this will be an issue as I've used them before without any issue.

Cheers, 

Greg

0 Kudos
Message 3 of 11
(146 Views)

Re: Strange UI response

Works fine on Win 7 32 Bit, with this loading

 

Win7_32bit.png

0 Kudos
Message 4 of 11
(111 Views)

Re: Strange UI response

Thanks Steve,

I've just tried replacing all the buttons with Silver styled buttons and it seems to work. I'll replace them all back to System and see what happens. 

Really strange and a bit annoying!

 

0 Kudos
Message 5 of 11
(99 Views)

Re: Strange UI response

Replacing all the buttons seemed to fix the problem. Seems a bit strange but will just keep an eye on it.

Thanks Steve for testing it on your system

0 Kudos
Message 6 of 11
(79 Views)

Re: Strange UI response

No worries matey,

I reckon the button instance had corrupted.

0 Kudos
Message 7 of 11
(72 Views)

Re: Strange UI response

Was first button corrupted and then copied to remaining buttons?

0 Kudos
Message 8 of 11
(56 Views)

Re: Strange UI response

Yes, but it worked perfectly when I originally wrote the software.

 

I did have to reinstall LabVIEW on my PC a few days ago which also reinstalled the System UI Control Suite using VIPM, where the buttons came from. Thinking about it, I should have tried a mass compile before replacing the buttons!

0 Kudos
Message 9 of 11
(51 Views)

Re: Strange UI response

It is never to late.

 

You have got broken version saved in source code repository, haven’t  you? Smiley Wink

0 Kudos
Message 10 of 11
(43 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.