CSLUG - Central South LabVIEW User Group (UK)

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2020 Community Edition

Hi All,

Following Sam's excellent demo with the Rasberry Pi last meeting, I've been inspired to register for the Beta Community Edition and try working with a RP myself. I've installed LabVIEW OK and established communication with the RP, however I can't get the system to register the application builder.

Has anyone else had issues ?

thanks

Adrian

 

0 Kudos
Message 1 of 8
(1,199 Views)

Hi Adrian, 

Have you tried reinstalling/repairing LabVIEW Real-Time from the Package Manager? Once I did this I could build RT applications. 

I have also been using the 2019 linx toolkit and manually installed 2019 runtime on the Pi. Its working really well.

Cheers,

Greg

0 Kudos
Message 2 of 8
(1,188 Views)

Hi Adrian, 

 

Yes - I had exactly the same problem and it was fixed by a repair of LabVIEW real-time. I think the LINX Toolkit uses parts of the RT tool chain (e.g. targets / build specifications) and something gets messed up?

 

Regards, 

Sam


LabVIEW Champion, CLA, CLED, CTD
MediaMongrels Ltd. - NI Alliance Partner (blog)
0 Kudos
Message 3 of 8
(1,173 Views)

Thanks Greg, I'll give that a try and post my findings.

By the way, the Albino Squid Assasin Clone is Excellent !

Cheers

Adrian

 

0 Kudos
Message 4 of 8
(1,158 Views)

Thanks Sam......seems Greg had the same issue so I'll try re-installing the real-time and post my findings

Cheers

Adrian

 

0 Kudos
Message 5 of 8
(1,157 Views)

Glad you enjoyed it. If you haven't had the Nox yet I've had a few and they are getting good, at least I think so!

0 Kudos
Message 6 of 8
(1,153 Views)

OK, so an update on where I am.....

I think perhaps I didn't explain the issue very well in the first place. The problem that I was having was that the application builder, database toolkit etc did not want to register (although LabVIEW installed onto the PC fine). For some inexplicable reason, these other items have now registered OK and licenced for 140 days........so I'm up and running.

I've created a simple application, deployed it to the RP and made it run on power-up.....all good !!!

Now, all I need is some (simple) way of creating a GUI for the RP itself. I know there are Web vi's etc and I could learn Python and use Tkinter but that all sounds too painful......any suggestions ?

thanks

Adrian

 

0 Kudos
Message 7 of 8
(1,089 Views)

I think WebVIs are probably going to be the easiest way to go if you want the GUI to be 'on' the RPi - if you want a starting point you can look at the source code for my DemocracyBot on GitHub.

 

The alternative (without needing to learn any new tech) would be to treat the RPi like a headless cRIO and write a LabVIEW host GUI application to communicate with it remotely in the usual ways (e.g. TCP/IP, Network Streams, NSVs etc.).

 

I've also got one of those Nextion GUI Modules (a touchscreen LCD display + onboard GUI processor + GUI editor) that I've been meaning to play around with.


LabVIEW Champion, CLA, CLED, CTD
MediaMongrels Ltd. - NI Alliance Partner (blog)
0 Kudos
Message 8 of 8
(1,087 Views)