BreakPoint

cancel
Showing results for 
Search instead for 
Did you mean: 

Incongruous sightings of LabVIEW/NI


@thols wrote:

Veritasium tries worlds strongest magnet: https://youtu.be/g0amdIcZt5I

 

thols_0-1679980038361.png

 


I have to brag a bit on the subject.  sth gave me a personal tour of the lab some time ago.  Very cool stuff there.  Like 12 milli-Kelvins cool!


"Should be" isn't "Is" -Jay
Message 151 of 178
(1,152 Views)

@JÞB wrote:

@thols wrote:

Veritasium tries worlds strongest magnet: https://youtu.be/g0amdIcZt5I

 

thols_0-1679980038361.png

 


I have to brag a bit on the subject.  sth gave me a personal tour of the lab some time ago.  Very cool stuff there.  Like 12 milli-Kelvins cool!


And the Easter Egg Basket Color Scheme was perfect for last weekend. 😄

Message 152 of 178
(1,131 Views)

@altenbach wrote:

@JÞB wrote:

@thols wrote:

Veritasium tries worlds strongest magnet: https://youtu.be/g0amdIcZt5I

 

thols_0-1679980038361.png

 


I have to brag a bit on the subject.  sth gave me a personal tour of the lab some time ago.  Very cool stuff there.  Like 12 milli-Kelvins cool!


And the Easter Egg Basket Color Scheme was perfect for last weekend. 😄


I was more surprised by the default B&W icon!


"Should be" isn't "Is" -Jay
0 Kudos
Message 153 of 178
(1,126 Views)

@JÞB wrote:
I was more surprised by the default B&W icon!

Well, toplevel VIs don't need a custom icon. I am more surprised that it even shows at runtime 😄

 

0 Kudos
Message 154 of 178
(1,121 Views)

@altenbach wrote:

@JÞB wrote:
I was more surprised by the default B&W icon!

Well, toplevel VIs don't need a custom icon. I am more surprised that it even shows at runtime 😄

 


If they hide the toolbar, they can't hit that pause button anymore 🙄.

0 Kudos
Message 155 of 178
(1,050 Views)

Ah, I see you are ragging on my artistic abilities!  I do have a few custom icons but since everything is in constant development the icons are last....  (Insert CCR song "Someday never comes")

 

Next check out the lack of documentation! 🙂  Of course this VI was originally built with LV 2.2.1 and has morphed many times since the mid-90s!  The graphics are certainly dated.  However it is robust with a lot of error checking and automatic recovery from various issues which is my main design criteria.  Not one of the 10,000 physicists who have used that VI actually mentioned the default icon.

 

However, the VI has to run in the development environment since many others use VI Server to talk to it and there is no way to make VI server talk to a built application on the MacOS.  Just one of those things that NI never got around to creating/fixing.  (and no the secret LV preference that is really an Active Directory command doesn't work on the MacOS).

LabVIEW ChampionLabVIEW Channel Wires

Message 156 of 178
(1,024 Views)

@sth wrote:

Of course this VI was originally built with LV 2.2.1 and has morphed many times since the mid-90s!.


... and I thought that LabVIEW 2.2 was B&W...

 

altenbach_1-1681231820993.png

 

 

But maybe not, according to the lower picture here. Can we "automate 30 year old technology" with 40+ year old technology? Yes, we can!

 

altenbach_1-1681232094540.png

 

Message 157 of 178
(1,015 Views)

@altenbach wrote:

@sth wrote:

Of course this VI was originally built with LV 2.2.1 and has morphed many times since the mid-90s!.


... and I thought that LabVIEW 2.2 was B&W...


I said it had morphed. 🙂

 

Adding color along the way.  But I mis-identified the VI.  That one was created in LV 4.X and finalized in LV 5.1 for that specific magnet when it became operational in June 2000.  It has then been updated up to LV 21 over the years and shares some graphics with the VI for running the other magnets in the facility.

LabVIEW ChampionLabVIEW Channel Wires

Message 158 of 178
(1,006 Views)

@altenbach wrote:

 

altenbach_1-1681231820993.png

 

 


For some reason the background of this image trips out my monitor when scrolling. It starts flashing blue/white.

0 Kudos
Message 159 of 178
(938 Views)

@AeroSoul wrote:

For some reason the background of this image trips out my monitor when scrolling. It starts flashing blue/white.


Same here. Must be a feature.

 

Recording doesn't capture the effect though. 

0 Kudos
Message 160 of 178
(916 Views)