Barcelona LabVIEW Academic User Group

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

Problema al graficar la señal de salida de una función de transferencia

Hola  a todos.

Bueno tengo un problema para graficar la señal de salida de una función de transferencia determinada. La señal de salida se visualiza pero antes de llegar a cero se reduce en amplitud. Estoy interesado en que esta señal no se "atenue". Para ilustrar el problema cree un Snippet. La señal de entrada es una señal cuadrada simulada, Freq= 10.1Hz, Amp = 1, offset=1, la cual se  aplica a un modulo de CD Linear Simulation (Transfer Function) cuya función es             H(s) = 1/sRC + 1  (es un modelo lineal). Posterior, la salida se aplica a un derivate function para obtener su derivada.  Cuando se grafican esa salidas de cada "proceso" sucede que la señal se atenua como pasa en la gráfica y además se corta apartir de 1 seg

¿Cómo obtener graficas las señales de "Volumen" y "Flow rate" sin que se atenúen cuando llegan a cero? La idea es que se visualice como si fuesen en tiempo real.   

Agradezco su gran ayuda.

Cualquier comentario: jairasir82@gmail.com

SimulatorPx_2016.pngdd.png

0 Kudos
Message 1 of 4
(4,088 Views)
3 REPLIES

Re: Problema al graficar la señal de salida de una función de transferencia

Hola jairasir16,

Creo haber encontrado el origen del problema y, de ahí, se me ocurren varias ideas para resolverlo.

En la reunión de mañana martes le dedicaremos 15-20 minutos a estos temas para encontrar entre todos la solución:

* ideas para localizar comportamientos anómalos

* uso de breakpoints

* continuidad de la función simulación

Después colgaremos aquí la mejor respuesta.

Hasta mañana!

Guillermo

0 Kudos
Message 2 of 4
(3,219 Views)

Re: Problema al graficar la señal de salida de una función de transferencia

Gracias por tu gran ayuda.

2016-03-28 23:47 GMT+02:00 GuillermoP <web.community@ni.com>:

NI Community <https://decibel.ni.com/content/index.jspa>

Re: Problema al graficar la señal de salida de una función de

transferencia created by GuillermoP

<https://decibel.ni.com/content/people/GuillermoP> in *Barcelona LabVIEW

Academic User Group* - View the full discussion

<https://decibel.ni.com/content/message/133157#133157>

0 Kudos
Message 3 of 4
(3,219 Views)

Re: Problema al graficar la señal de salida de una función de transferencia

Gracias por la alternativa que pudimos encontrar entre todos para solucionar el problema.

Soluciòn:

Configurar los parámetros de Simulate Signal.

solucion1.png

Gracias a todos.

0 Kudos
Message 4 of 4
(3,219 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.