BLT for LabVIEW (Build, License, Track)

cancel
Showing results for 
Search instead for 
Did you mean: 

How to select a build

Solved!
Go to solution

I renamed the build specifications for a project recently, and then tried to select the build spec so I could build/distribute.

 

However I can't seem to select the renamed build spec:

Ozfarmboy_0-1694843582053.png

 

I want to simply select one of these and move on - it doesn't need to be analysed because I simply renamed it.  But I can't seem to set one of the build specs in the list to be "default".

Is the only way to do this to run Analyze Builds?  I tried this but get an error:

Ozfarmboy_1-1694843673205.png

 

VI Server is set correctly - I have tested VI Server connection and it's connected.

Christopher Farmer

Certified LabVIEW Architect and LabVIEW Champion
DQMH Trusted Advisor
https://wiredinsoftware.com.au

0 Kudos
Message 1 of 3
(302 Views)
Solution
Accepted by topic author Ozfarmboy

Hi Chris, 

 

Indeed, you need to first Analyze the Build Specs to be able to select the renamed one.

It seems you're having an issue with the LabVIEW VI Server Connection Responsiveness.

 

I suggest you try to increase the value of the PingTimeout value as described here:

https://www.studiobods.com/help/bltforlabview/LabVIEWVIServerConnectionRespons.html

 

Hope this helps, let me know...

Cheers.



Matthias Baudot | Software Architect | Founder at STUDIO BODs


STUDIO BODs     BLT for LabVIEW     LabVIEW Champion     Certified Professional Instructor     DQMH Trusted Advisor     GCentral Sponsor


 Check out my LabVIEW presentations and videos!

Message 2 of 3
(258 Views)

I am running it on an Azure VM, and it tends to be on the slow side, so that may have been the main cause. 

I adjusted ping timeout from 180000ms to 360000ms and it worked this morning.

Christopher Farmer

Certified LabVIEW Architect and LabVIEW Champion
DQMH Trusted Advisor
https://wiredinsoftware.com.au

0 Kudos
Message 3 of 3
(251 Views)