Automotive and Embedded Networks

cancel
Showing results for 
Search instead for 
Did you mean: 

XNet 8502 Goes Away Randomly, USB Power Issue?

Solved!
Go to solution

So I have some USB-8502/2 devices (which are fantastic BTW).  And on my main development laptop I'm having problems where the device will just randomly disappear and come back.  I've tried multiple 8502s, and I've tried multiple USB ports on this computer.  I've also turned off the selective USB Suspend power settings.  While running an application I've at times gotten error -1074384718.

 

Spoiler
NI-XNET: (Hex 0xBFF630B2) The NI-XNET driver no longer can communicate with the device. Solution: Make sure the device has not been removed from the computer.

I launched MAX and just watched.  The Ready light on the device will be solid, and then after a few seconds blinks off, and then back on again.  Here is a video from MAX showing what happens.  During this video the device is just sitting there, plugged directly into the laptop with no hub and not running anything.  This is an older laptop but looking at the data sheet it says the power requirement is only 300mA and any USB port since 2.0 should be able to to do this, and these are labeled SS (SuperSpeed).  Any suggestions?  The devices themselves seem fine and can be used in other laptops, and desktops but my main development machine just doesn't like them.  This is Windows 10 x64, XNet 19.0, MAX 19.0.0 f0.

0 Kudos
Message 1 of 4
(171 Views)

This could help.

0 Kudos
Message 2 of 4
(120 Views)

Yup already did that which is what I meant by "I've also turned off the selective USB Suspend power settings."  I also made sure the "Allow the computer to turn off this device to save power" was unchecked in all the USB hub properties in the device manager.  I also plugged in the laptop to external power, and restarted the computer but it still behaved this way.

 

I couldn't find a powered external USB hub to test with, but I do have a dock.  And when the laptop is docked, and I plug into the 8502 into the same port on the laptop as before it works fine.  I'd still like to hear from NI if possible because I can't think of a reason this wouldn't work.

0 Kudos
Message 3 of 4
(102 Views)
Highlighted
Solution
Accepted by topic author Hooovahh

So after checking my power settings again I saw that in device manager there were a couple USB hubs that still had "All the computer to turn off this device".  I restarted a few times and now it is working again.  Just normal Windows weirdness I guess.

Message 4 of 4
(58 Views)