Automotive and Embedded Networks

Showing results for 
Search instead for 
Did you mean: 

Error loading "Ni845x.dll" invalid access to memory location

What are the change(s) in the New Patch that fixed the problem that was not detected in the First Patch?



0 Kudos
Message 21 of 25

Hi Guys,


I am having very similar issues... Using a NI-8451, Win XP SP3, LavView 2012 f3


I get the same error code. My drive is NTFS formated and I have a XP account with password.


ProjHunter, code you post the version number of the DLL you are successfulling running your code with? I currently have Ni845x.DLL version




0 Kudos
Message 22 of 25

Actually, the problem has been better identified and if you upgrade your DAQmx to a more recent version, that is the simplest method to make the problem go away. This happens to be a strange interaction between NI-DAQmx 9.2-9.4 (possibly earlier than 9.2, but that was the oldest version I tested with). If you install DAQmx 9.5 or newer, the problem should go away.


If you are unable to do that, let me know and I can provide you with a second workaround, but it is not quite as clean.

0 Kudos
Message 23 of 25

Thanks for the info.


I had DAQmx version 9.4 installed, I downloaded and installed DAQmx version 9.6.1


So far so good. The DLL loading error seems to be gone. I still need to do some testing but looks like that fixed it.




0 Kudos
Message 24 of 25

NI-845x 2.1.1 is released, which should fix this problem for people that do not want to upgrade their NI-DAQmx driver.

0 Kudos
Message 25 of 25