Automotive and Embedded Networks

Showing results for 
Search instead for 
Did you mean: 

Error loading "Ni845x.dll" invalid access to memory location



I am attempting to use a .VI built on a win7 machine (32bit, using labview 2011) on a different winXP machine (also 32bit, using labview 2011). When I start up the .VI in question, I get a messagebox with the error:


"Error loading "Ni845x.dll", Invalid access to memory location"


I have found the file in question at C:\WINDOWS\system32\, but the issue remains on the new winXP machine.


The one clue I have found is that the .VI was initially built using the 2.0 version of the NI usb-845x driver, while the new machine has the 2.1 version of the same driver.


Thanks in advance.

0 Kudos
Message 1 of 25

Can you post the VI so that I can attempt to reproduce this?

0 Kudos
Message 2 of 25

Actually, can you let me know more about the computer that is failing? Processor? RAM? Etc.

0 Kudos
Message 3 of 25

I am having the same issue.  Just when I try to drop a configure vi on the diagram.  "NI-845x I2C Create Configuration" (win xp sp3 Pentium D CPU 3.40GHz 1 GB of RAM)

0 Kudos
Message 4 of 25

What version of NI-845x are you using? 2.1 or an older version?

0 Kudos
Message 5 of 25

I was doing a NI Web Search and found that NI-845x 2.1 Driver had been develop in Aug 2012.
After Reading the Readme File (2.1 Driver) I notice that the feature that I having a problem
with (Changing the SPI Bit Transfer Size (4..64)) was added to this upgrade.


This Feature is added to the Basic SPI and the Script SPI LabVIEW API. So I download NI845x 2.1 Driver
from NI and installed it on my System (MS Win XP Prof SP3 Intel Core I7 CPU 620 Running 2.67GHz, 3.2GB RAM)
The install took about 35 Mins to Complete but no Errors was Reported. I executed the Shutdown command and
turned off my computer.


I Re-Boot my Computer and log-on and then connected-up my USB-8452 Controller. I Started LabView 2009
and start to run some of the VI that I had previously developed and Debugged with NI845x 2.0 Driver

The Error generated when I double clicked the VI to open it in LabVIEW Msg: 'Error Loading "NI845x.DLL"
Invalid Access to Memory Location'

I Did found the file "NI845x.dll" in my C:\WINDOWS\system32 Folder .


* Once the VI was open up in LabView I pressed the Run Button, the Error Generated "SubVI NI-845x DIO Write Port.VI :     SubVI is not Executable"

The subVI is not Executable. You must Fix all errors in the SubVI Before this VI can Run.
I then open up the SubVI  Block Diagram and pressed Run Button. The Error Generated "Call Library Function  Node"NI845xLVDioWRitePort':Library not found or failed to load"

The Library Specified for this node cannot be found or cannot be loaded. Right-click the call Library Function node  and select configure, then choose the correct Library name or path
* I click CFG and the Library name or path see Attached image file.

What is the problem My old VIs (developed w/NI845x 2.0) and the New VI (developed w/NI845x 2.1) does not RUN
the Same Errors reported above are generated when trying to RUN either VIs




^ Have anyone that has REPORT this similar Problems Had any success with a SOLUTION.??


The Error generated when I double clicked the VI to open it in LabVIEW Msg: 'Error Loading "NI845x.DLL"
Invalid Access to Memory Location'


I have tried to Repair the NI845x 2.1 driver under Remove//Install Programs |National Instruments|NI845x 2.1

I also tried  a un-install of NI845x 2.1 Update and a Re-install

I also tried a new down-load of NI845x. 2.1 driver and re-install


Now of the Corrective Action above solved the problem: 'Error Loading "NI845x.DLL"
Invalid Access to Memory Location'


I HAVE Submitted a Technical Support ticket of this Problem to NI Application Engr.

No Luck yet!

0 Kudos
Message 6 of 25

It seems my specific issue was solved when I downgraded from 2.1 to 2.0.  Also I have been running Labview 2011 Q3 on win xp 32 bit.

0 Kudos
Message 7 of 25

Question.. is your hard drive formatted with NTFS for FAT32?

0 Kudos
Message 8 of 25

Thanks for Replying!


But I need the New feature added VI  "NI-845x SPI Script Num Bits Per"  that is in NI845x 2.1 Update.

0 Kudos
Message 9 of 25

MY Hard Disk Files Format: NTFS

0 Kudos
Message 10 of 25