Actor Framework Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

You'd think it was a .NET problem, but it appears to be AF related

Solved!
Go to solution

I have an AF application that uses the .NET Calendar. It works fine in the IDE. When I tried deploying it to an EXE, I ran into problems. For the purposes of posting (not here, but in something more .NET apropos), I made a small, single VI application to demonstrate the problem. As soon as I did that, the calendar worked fine in an .EXE.

 

For some history, I did the due diligence of verifying that the .NET assemblies were present in the GAC on the target machine, along with some other investigation. It proved unnecessary as I've seemed to have isolated the problem to NOT being a .NET deployment issue, but rather somehow related to my larger AF application, though I'm not sure how.

 

I'm attaching a small application (single VI) and the project with the build spec. It's LabVIEW 2023, and my target machine has the dependent .NET assemblies in the GAC (yours may not). The EXE works fine on my target machine, but as soon as I attempt a similar implementation in a child actor in Actor Framework, I get the dreaded LabVIEW error code 1:

 

Error 1 occurred at Property Node in View.lvlib:View.lvclass:Actor Core.vi:5880001->Actor Framework.lvlib:Actor.lvclass:Actor.vi:6640004->Actor Framework.lvlib:Actor.lvclass:Actor.vi.ACBRProxyCaller.B3600002

Possible reason(s):

LabVIEW: (Hex 0x1) An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.

 

This occurs on the error out of the 1st property node connected to the .NET calendar control, implying an invalid reference to the calendar control.

 

I'm guessing this is simple oversight on my part, and that somehow, I've missed something. Any insight is much appreciated!

0 Kudos
Message 1 of 2
(874 Views)
Solution
Accepted by topic author johnny_icon

Turns out the fix in AF was to register for a .NET  Event Callback:

Registering and Handling .NET and ActiveX Events - NI

 

Works fine in AF now.

0 Kudos
Message 2 of 2
(798 Views)