Academic Hardware Products (myDAQ, myRIO)

Showing results for 
Search instead for 
Did you mean: 

myRIO 2019 Installation problem

I have problems installing software for myRIO (myRIO Bundle 2019)
I am using Win10, previously I had myRIO Bundle 2016 successfully installed. Before current upgrade I have safely removed all NI software using Add/Remove Programs feature.
I have tried 2 different ways of installation (Firewall and Antivirus disabled 😞
var A: Installing myRIO Bundle 2019 using NIPM,
var B: Installing software components manually/slowly as suggested by Bob Schor in his posts on the NI forums.
     step 1: only Labview2019 SP1; reboot
     step 2: only Labview Real-Time; reboot
     step 3: only Labview FPGA (no Vivado Tools); reboot
     step 4: myRIO Toolkit,
     step 5: Compact RIO Drivers, reboot
Both procedures were unsuccesful.
var A results in immediate Labview crash after starting Labview (Unrecoverable error).
var B results in functional Labview Application with properly installed toolboxes. After plugging in myRIO, Win10 detects device and pop-up window appears, but Getting Started Wizard fails to connect with myRIO. The error description is:
Unrecoverable Error: An error occured while attempting to check software installed on myRIO.
Error -2147220354 occurred at nisyscfg.lvlib:Get Installed Set
Possible reason(s):
NI System Configuration: The system must have a valid IP address before certain operations such as installation. The IP address cannot be
My observations:
  • I tried to fix IP in NI MAX, but NI MAX freezes on start-up "Loading plug-ins" . Restarting NI Configuration Manager and NI Device Loader in Services is not possible.
  • I have noticed that NI MAX failed to start even before step 3, so I believe the problem is not myRIO dedicated software.
  • I used repair feature for NI MAX in NIPM. NIPM was unable to repair NI Configuration Manager (MXS) and NI-RoCo (infrastracture).
  • myRIO device works without problem on other machine, so hardware malfunction can be ruled out.
I am attaching final list of installed packages (var B), error description and NI MAX startup window.
Download All
0 Kudos
Message 1 of 3

Steps 1-5 look good (and correct to me).  You probably have the right software installed to begin working with your myRIO.  Sadly, I've wrestled with too many "problematic" LabVIEW installations, but the LabVIEW 2019 install I thought went pretty smoothly.


Here are my suggested steps:

  1. Read the Private Message I sent you on the Forums, and respond to it.
  2. I suspect something went wrong in the previous Install.  There are some "Additional Features" you need to support the modules, toolkits, and drivers you chose.
  3. Ultimately, I think you'll need to "Uninstall all NI Software" (multi-step process, using NIPM to "Remove all", then a second pass to "Remove NIPM" (which should be the only thing left).
  4. After Steps 1 and 2, when you do the re-install, pay attention to the "Additional Features you'll need".
  5. After you have LabVIEW installed (and verified to work on your PC), plug in the myRIO, find it in MAX, and start configuring it.
    1. First thing is to update its Firmware.  Oops -- I plugged my own myRIO in to read off what its firmware and OS versions were, and forgot that kills my Network connection to the Forums.  I remember the Firmware was something like 8.8.0, but don't remember the version of the OS.
    2. I did ask you to expand the Software entry under your myRIO and take a screen snip of the listed software.  The Recommended set suggested by MAX for the myRIO is close to what I use (I add an additional Bell or Whistle).
    3. Report back here.

Bob Schor  




0 Kudos
Message 2 of 3

Before following Bob suggestions, I did the following:

It seems that NI MAX is having trouble immediatelly after first driver is installed (no Real-Time or FPGA modules installed). The NI MAX simply freezes on the start-up.

I tried to pin point the exact cause of NI MAX problem and I have noticed that even after removing NI Software (including NI PM) a bounch of files remains in C:\Program Data, which seems to be expected behaviour - NI Package Manager Cache.


So reinstall just Labview 2019 SP1 with drivers and followed these instructions:

Manually Resetting the NI Measurement & Automation Explorer Database

Reset and Fix the NI Measurement & Automation Explorer Database File


That does not help. If NI Configuration Manager service is stopped, then NI MAX opens but then prompts me that a running CM service is required...

0 Kudos
Message 3 of 3