Academic Hardware Products (myDAQ, myRIO)

cancel
Showing results for 
Search instead for 
Did you mean: 

USB DAQ software connection help

 

Hello, 

 

I don't have very much experience with any of this National Instruments software. I am having trouble connecting and configuring/ calibrating an FLS-1 Portable Mechanical Tester to my laptop, with the NI Max app version 16.0. Under the model name in the settings, it says it is USB DAQ and the computer display for the USB connection says NI USB- 6002 (OEM). I am doing a project testing toughness of fruits. When I push on a load cell or turn the handle to see if the load and displacement are registering nothing happens (the computer is not reading the tester). I have tried all the different programs with both load cells and the readings are all the same, as well as adding a random arbitrary calibration factor where there is a place to enter the calibration to see if the problem was that it was not registering the calibration file. I tried switching the USB ports to see if there was an issue there and it still reads zero. There is a blue light that lights up when the tester is connected to the computer as well. Under devices and interfaces the device shows up (model USB DAQ) and it says status: “present” but I cannot right-click anywhere or get any self-test for the device to show up and, therefore, when I run the program there is no output coming from the device. I am not sure if this is a connection, configuration, or calibration issue or another issue entirely. 

 

It also does not have a name registered in MAX under settings (it is blank) but when I try and rename it by going to tools -> NI-DAQmx Configuration -> Reassign Device Names to Default Values there are two options for the DAQmx configuration file, a local option which brings me to an error message saying “error when reassigning device names to default values. Possible reasons: storage specified is not valid or could not be found”. The other option Remote prompts me for an IP address or target name. In this section I have added the computers IP or random numbers but it always ends with the same error message saying: unable to connect to the remote system “reason for error: the specified feature has no been implemented for the environment. The operation could not be completed as specified”. I am not sure if there is another way of naming the device or if this would even fix the problem. 

 

Under the help bar -> Help topics -> NI-DAQmx Under configuring and renaming DAQ devices it says to right-click the device or select the device you want to configure, click configure in the MAX toolbar. When I choose the NI-DAQmx USB Driver Selector there is a pop-up screen saying to go to the ni.com website for more information on how to switch the drivers of the USB DAQ device between NI-DAQmx and NI-DAQmx Base (I am not sure if this is what the issue is relating to).

 

I have tried resetting the configurations, updating the system, and installing all the critical updates with the NI update service. I have also tried running a MAX report wizard: Technical support report (not sure if that is relevant to my problem or if it would be useful) and it comes up with the error message saying: “Unexpected Internal Warning, visit ni.com/info and enter the info code MAXKnownException for more information”. I have gone to the website and looked at all the different forums but I am still unsure as to what my next steps should be. 

 

Thanks for any help and suggestions, I really appreciate it!

0 Kudos
Message 1 of 1
(183 Views)