Academic Hardware Products (myDAQ, myRIO)

cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with Parallel inductance distortion

I'm having some problems using the myDAQ function generator. Placing a 1mH inductor in parallel with the function generator distorts the output a lot.

Does anyone have a solution to this problem?

Without inductor:

aoo200_0-1613677473998.png

With inductor in parallel:

aoo200_1-1613677542084.png

 

 

0 Kudos
Message 1 of 4
(84 Views)

If you put a 1mH in parallel (not in series), well read the spec of your myDAQ (output impedance and max output current)

 

calculate the complex load you apply with your 1 mH @ 100 Hz (you can measure additional parameters of your inductivity or look them up in the datasheet, since a more realistic model of your REAL component contains some more parameters 😉 )

 

??

 

What you migth see in your second measurement ..  What happens with an DAC output while abused .. it migth produce high frequency current artifacts that run into your inductivity ...    How was the formular for inductivities,current and voltage? 

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 2 of 4
(46 Views)

I had a short look into the myDAQ spec...  max output current seems to be 2mA.

 

What do want to do?

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 3 of 4
(41 Views)

Hi, thanks for your response. 

I  want to build a band pass filter but when I add the inductor, the output distorts. I have added a 470Ω resistor before connecting the inductor which has removed the distortion but i'm still not sure about why it occurs.

 

Thank you!

0 Kudos
Message 4 of 4
(34 Views)