Academic Hardware Products (myDAQ, myRIO)

cancel
Showing results for 
Search instead for 
Did you mean: 

Generate Sine wave on analog port of myRIO

Dear,

             Plz see the image. We recognize that slow behaviour of my rio because of for loop

0 Kudos
Message 21 of 28
(492 Views)

please see my previous reply as well as when I have tried code targeting to Myrio  FPGA I got the attached error

0 Kudos
Message 22 of 28
(490 Views)

What does the Xilinx Log report include? I suspect this has to do with the datatype. Is there a reason you want to include the chart in your FPGA VI? This is not a typical use case, and I recommend you refer to some of our resources for LabVIEW FPGA: http://www.ni.com/tutorial/14532/en/.

0 Kudos
Message 23 of 28
(476 Views)

I tried the same FPGA code and it did compile correctly. I used the NI's cloud compile option.

 

I see in your code that you are using a Wait (ms) function, inside a Timed Loop. You might want to fix this, so the loop can actually run at the requested frequency.

0 Kudos
Message 24 of 28
(472 Views)

Dear Sir,

Is there any limitation with use of math script node while programming NI my RIO 1900 ?

particularly use of for loop

0 Kudos
Message 25 of 28
(465 Views)

Manya,

 

Certain Mathscript functions are not supported on RT targets, such as the myRIO, and some of them only when you assign the output of the function to a MathScript variable. More information here: Unsupported LabVIEW Features on NI Linux Real-Time Targets, and here: Support for MathScript Functions in Real-Time Applications (MathScript RT Module). I don't see any specified limitations using For Loops.

 

Warm regards,

0 Kudos
Message 26 of 28
(454 Views)

Currently I am using NI My RIo In FPGA mode

 

I want to code it in a real time mode

but when I click New project and Say finish it shows fallowing errors

 

Error 8 occurred at List Folder in NI_NPW_Project Copying.lvlib:CopyUserProject.vi->NI_NPW_Project Copying.lvlib:CreateUserProject.vi->NewProjectDialog.vi

 

 

Possible reason(s):

LabVIEW: (Hex 0x8) File permission error. You do not have the correct permissions for the file.

C:\Users\205-10

0 Kudos
Message 27 of 28
(34 Views)
Highlighted

This seems like a different question than the one in this thread, manya, I recommend you start a new one to ensure your post is seen by the community and we keep solutions as clear as possible for other users who might benefit from them.

 

Regarding your error, it is stating it doesn't have permission to access a file. I recommend you ensure the directory where you are creating your project can be accessed by LabVIEW and does not require file permissions that your user or the software doesn't have. You can try creating it in the Public Documents folder and see if it throws the same error.

0 Kudos
Message 28 of 28
(22 Views)