Academic Hardware Products (myDAQ, myRIO)

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error -10401 occurred at AI Group Config -

Error -10401 occurred at AI Group Config -

Hi,

 

I am using PXI-6115s to drive and sense with piezos. I have a Labview VI for this which uses Traditional NIDAQ. When I run it I get the following error message,

 

Error -10401 occurred at AI Group Config -

|NI-DAQ LV:  The specified device is not a National Instruments product, the driver does not support the device.......

 

I have ver 4.5 of the NI measurement and explorer and I am able to run panel self-test. I have also been able to successfully run the hardware with NIDAQmx and Matlab.  Although, when I use the traditional NIDAQ driver in MATLAB the system hangs very often. Thanks in advance for your help!

 

Muhammad Haroon

 

0 Kudos
Message 1 of 3
(5,528 Views)

Re: Error -10401 occurred at AI Group Config -

Since it is working with DAQmx, why don't you just write the program with those functions instead of the obsolete traditional DAQ?

 

I suspect that the only reason you are getting the error is that MAX is setup to use the DAQmx driver. In order to switch drivers, see this.

Message 2 of 3
(5,524 Views)

Re: Error -10401 occurred at AI Group Config -

I am completely new to Labview and am using someone else's Vi which they have successfully used before but with an older version of MAX. I have tried resetting the drivers and still get the same error. I also reinstalled the hardware.
0 Kudos
Message 3 of 3
(5,518 Views)