NI Home > Community > NI Discussion Forums

Wireless Sensor Networks

Showing results for 
Search instead for 
Do you mean 
Reply
Member
Nonegatives
Posts: 4
0 Kudos

WSN not showing in MAX

I am not seeing the WSN add-in options in MAX.  I have reinstalled and repaired, the WSNProvider help file was not installed, but the shortcuts are there.  The Network Browser works and I am able to see the Gateway in Project Explorer.  It seems all of the configuration is done in MAX?

 

Thank you.

Member
Nonegatives
Posts: 4
0 Kudos

Re: WSN not showing in MAX

A change in installation options solved it.

Member
Nonegatives
Posts: 4
0 Kudos

Re: WSN not showing in MAX

Is there another way of installing drivers into MAX?  Also, is there any documentation on the 9792 console commands and .ini files for setting up?

Member
VTHokie
Posts: 123
0 Kudos

Re: WSN not showing in MAX

Hi Nonegatives,

 

Your best resource is probably the NI 9792 WSN Real-Time Gateway User Guide and Specifications.  I'm not finding any specific ini settings since normal circumstances don't typically require editing the ini file.

 

Thanks,

 

- Greg J

Member
Nonegatives
Posts: 4
0 Kudos

Re: WSN not showing in MAX

I can see the gateway now, but I can not add nodes.  The "help" tells me to select the WSN Nodes tab which does not exist. 

Member
MegaHertz
Posts: 61

Re: WSN not showing in MAX

Hi Nonegatives,

 

The WSN Nodes tab is at the bottom of your MAX window, as shown below. It should appear when you have the WSN gateway selected under Remote Systems.

 

AddNodes.png

 

Are you not seeing it there?

Andy H.
National Instruments
Member
elgeeko
Posts: 4
0 Kudos

Re: WSN not showing in MAX

Can you describe what steps you took to resolve the issue?

Member
BRLUIZFELIPPE
Posts: 25
0 Kudos

Re: WSN not showing in MAX

I am facing the same problem. When I select the NI-WSN 9791 in MAX, I can find the "WSN node" tab. But, when I select the WSN 9792 gateway on the tree, there is no "WSN node" tab. What should I do?

_____________________ _ _ _ _ _ _

"Together we stand, divided we fall..."

Certified LabVIEW Associate Developer






Member
Sanjay_C.
Posts: 64
0 Kudos

Re: WSN not showing in MAX

Hi,

 

If you are using the NI WSN 9792 Gateway, you can reach the WSN Node configuration by doing the following:

1. Expand the 9792

2. Expand the Devices and Interfaces Tab under the 9792

3. You should find an item under Devices and Interfaces titled 'WSN'. Clicking on this will take you to the same configuration window.

 

The reason that it's in a different place for the WSN 9792 is because the 9792 has a real-time controller on it, and so wsn nodes will show up as 'Devices/Interfaces' to the real-time controller. The 9791 on the other hand, is simply a router, and hence has a tab for WSN nodes. I hope this sheds some clarity on the difference.

 

Capture.PNG

Sanjay C.
Embedded Software Product Manager| National Instruments
Member
elgeeko
Posts: 4
0 Kudos

Re: WSN not showing in MAX

I'm afraid the issue does deeper than this. If the software is not correctly installed on the programmable gateway, then the WSN does not appear under devices and interfaces. The WSN software was listed as installed on the target. I finagled with the software installation and somehow got the WSN to appear as a device, but I do not remember exactly how I did this.

 

To recreate the problem, I suggest formatting the target and starting with a blank installation.