NI Home > Community > NI Discussion Forums

Wireless Sensor Networks

Showing results for 
Search instead for 
Do you mean 
Reply
Member
yohanz
Posts: 4
0 Kudos

Re: WSN not showing in MAX

:smileytongue:hahaha,thanks for every body here ,i have already resolve my problem that is wsn-node can been seen in max.

my reason is that i input a wrong serial number for each node .(actually at the very start i don't know what is serial number used for ......:smileywink:)

Member
Archie Flores
Posts: 7
0 Kudos

Re: WSN not showing in MAX

Hi, I'm using the NI 9792 and I can see it in MAX (the computer identify the 9792) but I cannot install the WSN software to it. MAX doesn't show the Software section under Remote Systems. What could be?

Member
Andrew_B
Posts: 94
0 Kudos

Re: WSN not showing in MAX

Hello Archie,

 

This is Andrew Brown, an Applications Engineer from National Instruments. I would appreciate if you could answer the following questions:

 

1. What version of NI-WSN do you have installed?

2. What version of MAX do you have installed?

3. If you expand the WSN 9792 within MAX, do you have the "Devices and Interfaces" option appear?

 

You can determine the versions for the first two questions by expanding My System»Software within MAX. I would also appreciate if you could post screenshots of the issue.

 

Regards,

 

Andrew Brown

Applications Engineer
National Instruments
Member
Archie Flores
Posts: 7
0 Kudos

Re: WSN not showing in MAX

-I have the version 1.2.1 of NI-WSN, but it appears like NI-WSN 1.2.

-The version that I use of MAX is the 5.0.

-Yes, the Software and Devices and Interfaces section don't appear under Remote Systems.

 

I actually use LabVIEW 2011.

Member
Archie Flores
Posts: 7
0 Kudos

Re: WSN not showing in MAX

Do I need NI-WSN 1.3.0?
Member
Andrew_B
Posts: 94
0 Kudos

Re: WSN not showing in MAX

Hello Archie Flores,

 

Thanks for posting the additional information. To answer your question, you should not need to use NI-WSN 1.3.0 according to the NI Software Version Support for NI WSN Devices. On the 1.JPG image you posted, I noticed that your device has the status "Inconsistent IP Settings". This is probably the root cause of why you cannot see the software tab in MAX. Steps to fix it can be found at this KnowledgeBase article.

 

Please let me know if the problem still occurs with a different WSN device status.

 

Regards,

 

Andrew Brown

Applications Engineer
National Instruments
Member
Andrew_B
Posts: 94
0 Kudos

Re: WSN not showing in MAX

Hello Archie Flores,

 

Another note on your 9792 issue is that you have the time server set to 0.0.0.0 . Another possible fix for your issue is to configure this time server on your 9792. An article on how to do this is How Do I Configure My Time Server on the NI WSN-9791 or NI 9792 Gateway.

 

Regards,

 

Andrew Brown

Applications Engineer
National Instruments
Member
Archie Flores
Posts: 7
0 Kudos

Re: WSN not showing in MAX

I fixed my issue. It was the IP of the NI-9792. Thank you very much!