NI Home > Community > NI Discussion Forums

Volume License Manager and Automated Software Installation

Showing results for 
Search instead for 
Do you mean 
Reply
Member
Posts: 27
0 Kudos

VLM and silent install

Hello,

 

I want to create a silent installer for NI software, which is licensed via VLM. When I start to generate my specific nisuite.xml file, I get the message to use the parameter /groups. Unfortunately I do not find any hints how to use this parameter, the web page I found using the hints given in the pop-up window is not helpful for my case.

 

To specify my needs: I am using an Academic license and I want to generate an automatic installation for computers in a lab, which should all have the same installation, independent from the user. Therefore it would be fine, if every computer would get his license automatic without any input during the installation.

 

Michael

 

Active Participant
Marco_Brauner
Posts: 638
0 Kudos

Re: VLM and silent install

Hi Michael,

 

the process for creating silent installers with different options for VLM- or non-VLM- based installers

is described in these KBs:

 

http://digital.ni.com/public.nsf/allkb/878FC4C374013ADF8625733D00688F67?OpenDocument

 

http://digital.ni.com/public.nsf/allkb/AA2371E815A418DD86257169005F2D99?OpenDocument

 

http://digital.ni.com/public.nsf/websearch/D9DE5FB35F19F8A28625735C007C4AA1?OpenDocument

 

 

 

please walk throug the process and try it out.

 

 

Marco B. NIG

Member
Oli_Wachno
Posts: 177
0 Kudos

Re: VLM and silent install

Hi Michael,

 

I remember having had a similar (maybe the same) problem. I think, the group parameter does not appear anywhere in the documentation.

At the moment, I have no access to what I did back then, but I remember I had to experiment with the /groups parameter.

 

I think I used either /groups  or  /groups none on the command line

 

But don't beat me if it's not.... ;-) As soon as I remember, I'll let you know!

 

 

Oli

Programming languages don't create bad code, programmers create bad code....
Member
Oli_Wachno
Posts: 177
0 Kudos

Re: VLM and silent install

Hi Michael,

 

I guess you tried creating the spec file usind something like

 

setup.exe /generatespecfile c:\temp\spec.ini

 

If you get an error concerning groups you might want to try

 

setup.exe /generatespecfile c:\temp\spec.ini /groups ""

 

Can you check if this works for you?

 

Good luck

Oli

 

Programming languages don't create bad code, programmers create bad code....
Member
Posts: 27

Re: VLM and silent install

Hello Oli,

 

meanwhile I found a hint on a NI webpage (don't ask me whichh one). The solution there was similar to yours, to use the parameter

 

/group {}

 

in the call of setup.exe. This worked fine.

 

Thank you for your answer!

 

Michel

 

 

Active Participant
Alex_Pi
Posts: 328
0 Kudos

Re: VLM and silent install

[ Edited ]

Think thats from here:

 

Why am I Unable to run a Volume License Installer Silently Without Using Groups?
http://digital.ni.com/public.nsf/allkb/0DA0176CDD9732AD862577BA00502BFC?OpenDocument