NI Home > Community > NI Discussion Forums

Real-Time Measurement and Control

Reply
Member
Mohammed.Ashraf
Posts: 88
0 Kudos

NI 9802 mounting with (Run as Startup) RT application

Dear all

I hope my message find you all well !

 

We've done a project which was a climatic Chamber control , using the sbRIO 9641 with NI 9802 SD Card Module

we usually save the data logged during a test cycle using the Mount SD Card InvokeMethod at the RT , the FPGA is just doing some sensors acquisition and scalling , but as i mentioned saving and reading is done from the RT.

 

next , after mounting , i can access the files inside the SD using the drive letter , I then collect all the file names available and send them all to the host (list box)

 

user can choose one of the available file from the list box and then can retreive it's data , and so on

 

things go perfectly , until i decided to build the RT VI to be as (Run as startup) while we are at the end phase of the project.

I found that the files retreived is something else , everything stopped and i can view such files as shown below :

 

sd problem.jpg

 

I don't know where are those files located , and if there is any precautions i should take when deploying my RT VI as "Run as startup" 

 

Looking forward to hearing from you :smileyhappy:

Best Regards

 

Eng. Mohammed Ashraf
Certified LabVIEW Associated Developer
InnoVision Systems Founder, RF Test Development Engineer
www.ivsystems-eg.com
Member
David-A
Posts: 172
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

[ Edited ]

Hello Mohammed,

 

The files you are seeing are located in the root directory of the RIO.  You can see this by opening windows explorer and typing in the IP address of the RIO preceded by "ftp://".  What is likely happening is that when you deploy the application as startup it is being placed in the /ni-rt/startup/ directory which is different from the directory you have been using.  Confirm that you are navigating to the correct location irrespective of the directory the application is located in.

 

David A

National Instruments
FlexRIO Product Support Engineer
Member
Mohammed.Ashraf
Posts: 88
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

Dear David

Thanks alot for your reply

 

I use the Invoke method 'Mound SD Card' , and it has an output called 'Drive letter' , my files is in that drive letter root (e.g. u:\) 

it works fine when under development , but once deployed , i don't know what's go wrong although i used this 'Drive letter' output to access the files there

Eng. Mohammed Ashraf
Certified LabVIEW Associated Developer
InnoVision Systems Founder, RF Test Development Engineer
www.ivsystems-eg.com
Member
David-A
Posts: 172
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

So is the issue that you do not know where the files shown in the listbox in your original post are located?  Or is the issue that you cannot access files on the SD Card that would normally show up in that listbox?  Regardless, you may want to confirm that you have the most recent version of the RIO driver.  You can find the most recent version here which is version 4.0.  If you already have the most recent version or updating does not resolve the issue please post your code or a screenshot of the code that is not functioning properly when deployed.

 

David A

National Instruments
FlexRIO Product Support Engineer
Member
David-A
Posts: 172
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

You may also want to try deploying some of the examples for the 9802 found in the example finder.  If you open up the example finder and navigate to Toolkits and Modules>>FPGA>>CompactRIO>>Module Specific>>File Input and Output you will find several example for the 9802.  The NI 9802 Write.lvproj and the NI 9802 RT Access.lvproj would both be good examples to test out.

 

David A

National Instruments
FlexRIO Product Support Engineer
Member
Mohammed.Ashraf
Posts: 88
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

Dear David

Thanks alot for your rreplies

 

actually I tried the mounting SD card example in the module specific examples shipped with labview

the strange thing is that it worked well , but with my program , it behaves the strange way i discussed earlier.. same code regarding the mounting and unmounting , does it related to the size of the program ?! sounds odd but just asking 

 

Anyways ,meanwhile I am downloading the latest RIO drivers and will update you

Please if you have any clarifications tell me about it , and soon today i will post that part of my code here

 

Best Regards..

Eng. Mohammed Ashraf
Certified LabVIEW Associated Developer
InnoVision Systems Founder, RF Test Development Engineer
www.ivsystems-eg.com
Member
Franjo_Tonkovic
Posts: 5
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

Hi,

I am just experiencing exactly the same problem as you have described! Did you manage to solve it, how?

Thanks for your help,

Regards

Franjo Tonković

Member
David-A
Posts: 172
0 Kudos

Re: NI 9802 mounting with (Run as Startup) RT application

[ Edited ]

I would recommend building a debuggable executable and watching where it fails and then comparing what you are doing to existing code that works. Examples of existing code can be found in the example finder. An interesting example that uses a startup exe to access an SD card through the 9802 can also be found here.

National Instruments
FlexRIO Product Support Engineer