NI Home > Community > NI Discussion Forums

PXI

Reply
Member
VuDuSuWu
Posts: 2
0 Kudos

unknown device: pxi-5401

Issue is that after installing Windows7 the device manager displays "unknown device" for function generator PXI-5401 even though other NI data acquisition devices are recognized.  Tried updating installation with software version 2.9.  Tried compatability mode for device to go back to using Windows XP and even Windows 95, but the FGEN softpanel still won't work because the device is still not recognized.  Any advice for getting the PXI-8186 computer to recognize the PXI-5401 device driver?

Member
VuDuSuWu
Posts: 2
0 Kudos

Re: unknown device: pxi-5401

It's listed as "PCI device" under "Other Devices" in Device Manager window.  Went to PCI device properties >> update driver >> search automatically for updated driver software (failed), browse my computer for driver software >> selected C:\USERS\NI\DOWNLOADS\NIFGEN290 where I downloaded the software update version 2.9 for NI PXI-5401 from NI website (failed), "Let me pick from a list of device drivers on my computer" >> NI "Data Acquisition Devices" >> no PXI-5401 available (PXI-5402 was available)

 

Attempted right click "PCI device" from Device Manager >> "Scan for hardware changes"

Result:  "Device driver software was not successfully installed", "PCI Device:  no driver found"

 

When attempting autorun from downloaded software update:

C:\USERS\NI\DOWNLOADS\NIFGEN290 >> launch autorun application >> select "Install NI-FGEN 2.9" >> "Select features to install" with long list of LabVIEW supports 2009-2011 and more, most of which have option to "leave this feature installed locally"; NI-DAQmx 9.1.7 with green checkmark next to "This feature will not be installed."

 

Should I uninstall this stuff and try to reinstall again?  How would I uninstall?

 

What can I do to make the NI PXI-8186 embedded controller in a NI PXI-1042 chassis recognize the NI PXI-5401 function generator?

Note:  PXI-5401 function generator is recognized and works in separate PXI-8186 running on Windows XP

 

Member
MikhailK
Posts: 148
0 Kudos

Re: unknown device: pxi-5401

Hi VuDuSuWu,

 

It looks like NI FGEN 2.9 driver does not support pxi-5401 on Windows 7, however it does support pxi-5402. Refer to the "Supported Hardware" table in the driver readme file. NI FGEN 2.9 supports pxi-5401 on WinXP only.

I have checked previous versions of the NI FGEN driver and it looks like none of them support Windows 7:

 

"Windows 7/Vista does not support Traditional DAQ (Legacy) devices. Traditional DAQ devices include the NI PXI/PCI-5401, NI PXI/PCI-5411, and NI PXI/PCI-5431. Simulating these devices is also not supported on Windows 7/Vista, using either the NI-FGEN or the FGEN Soft Front Panel. Simulating a device that is not supported on your operating system results in indeterminate behavior."

 

Also for the future, to uninstall any of the NI drivers go to Windows Control Panel -> Add/Remove Programs -> National Instruments Software -> Uninstall/Change ---> and then select the driver you need to uninstall

 

Let me know if you have any further questions.

Mikhail
RF Toolkits, Product Support Engineer
National Instruments
Member
DaMuVuDu
Posts: 1
0 Kudos

Re: unknown device: pxi-5401

Thanks for that confirmation.  That's what I feared, so I worked with VuDuSuWu and we uninstalled Windows 7 to successfully reinstall Windows XP.  Now Windows XP does not recognize the ethernet driver preventing any further downloads, updates, network connection, etc. necessary to install the rest of the drivers.  We have NI LabVIEW software on disk but this has already been installed.  How can we get the NI PXI-8186 to recognize the ethernet port?

Member
MikhailK
Posts: 148
0 Kudos

Re: unknown device: pxi-5401

Hi DaMuVuDu,

 

The drivers for the network card can be found in the following directory on your PXI 8186 controller:

 

PXI-8186/8187
-------------
c:\Images\Drivers\Enet\Intel_100

 

For more information on installing the drivers on your  PXI 8186 refer to section "Software Driver Installation" on page 44 in the user manual.

Mikhail
RF Toolkits, Product Support Engineer
National Instruments
Member
judyjp
Posts: 3
0 Kudos

Re: unknown device: pxi-5401

why is it okay that the 5401 is not supported by daqmx? I have a perfectly good board that I can't use and now I have to buy a new. Do I get a discount?

Member
MikhailK
Posts: 148
0 Kudos

Re: unknown device: pxi-5401

Hi,

 

NI 5401 is function generator and requires NI-FGEN driver to program the device. NI-DAQmx is a different driver that is used to program our MultifunctionDAQ cards, it cannot be used to program NI 5401.

If you have NI 5401 all you need to do is install NI-FGEN driver to be able to commuinicate and program your card.

Mikhail
RF Toolkits, Product Support Engineer
National Instruments
Member
judyjp
Posts: 3
0 Kudos

Re: unknown device: pxi-5401

this is completely untrue. in oder for fgen to recognize the 5401 card is must be support by a driver that exits in windows 7. I just tried it. only ni-dag recognizes the 5401 and ni-daq is not supported by windows 7 either. Max does not recognize the 5401 using windows 7 and labview 2012. if max does not get, nobody does (fgen, labview.....).

Member
MikhailK
Posts: 148
0 Kudos

Re: unknown device: pxi-5401

[ Edited ]

Hi,

 

As I have mentioned before you cannot use NI-DAQmx to program NI 5401 function generator. It needs and NI FGEN driver.

Untitled.png

 

However, as you have pointed out, you can also use Traditional DAQ (not DAQmx) driver to program NI 5401.  Traditional DAQ driver is not supported on Windows 7:

 

"The NI 5401, NI 5411 and NI 5431 are Traditional DAQ devices and are not fully supported on Windows Vista or Windows 7. Simulating these devices are also not supported on Windows Vista or Windows 7 using either NI-FGEN or the FGEN Soft Front Panel."

 

Refer to the following articles for more information:

KnowledgeBase 5YJBJS31: NI-FGEN Compatibility with Windows OS

KnowledgeBase 5YO8UK31: NI-FGEN Compatibility for NI-FGEN Cards

Traditional DAQ and NI-5401 Signal Generator

 

I hope this clarifies things.

Mikhail
RF Toolkits, Product Support Engineer
National Instruments
Member
judyjp
Posts: 3
0 Kudos

Re: unknown device: pxi-5401

you obvioulsy have not used the device on windows 7. I have ni fgen drivers installed. they do not recognize the 5401 board in windows 7. I opened the soft front panel for fgen. no 5401. it does not see a device that is recognizes and asked me if I want to set up a virtual device.