NI Home > Community > NI Discussion Forums

PXI

Showing results for 
Search instead for 
Do you mean 
Reply
Member
Sharmi
Posts: 71
0 Kudos

Re: trans-receiver system using PXI

Hi Sarah,

 

Sorry I forgot to add one more point in the post above.

In the example you sent me, I know the slot for the RFSG Resource name but for RFSA, if I go to Measurement & Automation, I do not see any slot for RFSA under NI PXIe-1075. 

Can I use any one of the three slots of VSA as a Resource name for RFSA?

 

Thanks so much,

Sharmi

Active Participant
Sarah_Y
Posts: 247
0 Kudos

Re: trans-receiver system using PXI

Hi Sharmi,

 

It sounds like either you have an old version of the RFSA/RFSG drivers installed, you don't have RFSA/RFSG installed at all, or you chose not to install the examples/documentation.  Both of those problems can be solved by reinstalling the drivers.  You can find them linked on my first post.

 

Regarding the demodulation, quadrature modulation and demodulation is simple to do in LabVIEW if you use the Modulation Toolkit (one VI actually).  There is also an example called "MT niRFSA QAM Demod.vi" that comes with Modulation Toolkit that you should be able to use without having to edit much.  From the names of the files that you said you found, you may already have Modulation Toolkit installed.  If not, you can download it here.

 

For your second post about setting up things in Measurement & Automation explorer (MAX), you have to tell MAX that the 3 cards go together.  Looking under Devices and Interfaces, find the 5601.  Right click on it and select Properties.  It will pop up a window that allows you to select a digitizer (the 5622) and an LO (the 5652 that isn't being used as your signal source).  After you click OK, MAX now knows that you have an RFSA device instead of 3 separate devices.  In the LabVIEW example, whatever name you gave to your 5601 is the name that should show up on the drop down menu for the RFSA Resource Name.

 

Sarah Y

SDR Product Manager
National Instruments | Ettus Research