NI Home > Community > NI Discussion Forums

Multifunction DAQ

Showing results for 
Search instead for 
Do you mean 
Reply
Member
terminalman90
Posts: 14
0 Kudos

The application failed to initialize properly (0x0000142)

I am getting two errors that I think are related. Our project uses Labview 2009. I tell you the sequence of events. I received code from a workmate who was installing DAQmx code into our project. I tried to load his code on my computer. Our legacy code used Traditional DAQ routines. When I tried to load the VIs I repeatedly got the error "Error loading 'nilvaiu.dll', A dynamic link library (DLL) initilization routine failed." for any vi's that were DAQ related. I put in the driver disk and uninstalled all traces of DAQ. Then I reinstalled the drivers and restarted my computer. On restart I got this second error "The application failed to initialize properly (0x0000142). Click on OK to terminate the application." I found the following Knowledge base article: http://digital.ni.com/public.nsf/allkb/8355753BD0C8E62F8625768C005B359B which would seem to indicate that the installation did not complete because of memory issues. I do not have a server. How can I get DAQmx to run on XP?
Active Participant
Mr.F
Posts: 332
0 Kudos

Re: The application failed to initialize properly (0x0000142)

Hello,

 

Is this initialization error repeatable? The knowledgebase article you linked references a particular feature of some x86 processors called Physical Address Extension (PAE) that enables more than 4GB of physical memory to be used in 32-bit systems. Not necessarily that you are using a server. Do you have PAE enabled? What Version of DAQmx are you using? Can you open Measurement and Automation Explorer and see and use your device there?

Matt
Applications Engineer
National Instruments
Member
terminalman90
Posts: 14
0 Kudos

Re: The application failed to initialize properly (0x0000142)

[ Edited ]
For those reviewing this to find their solution, I'll answer Matt's questions:

"Is this initialization error repeatable?"
Yes. Every time I rebooted the computer, DevMon would fail. I was able to load my LabVIEW 2009 project file. I had additional problems with any VIs that had DAQmx or traditional DAQ dll references.

"Do you have PAE enabled?"
Not that I was aware of, but as it turns out, this was not the problem.

"What Version of DAQmx are you using?"
Under the instruction of an NI phone support person, I installed DAQmx 9.1.1 It did not change the situation.

"Can you open Measurement and Automation Explorer and see and use your device there?"
I never got this far. There was no device connected.

Since this posting I have used the uninstall directions contained here:

Clean Reinstall Procedure.doc

... provided to me by the phone rep. This procedure removes nearly ALL traces of LabVIEW. I had serveral version (7.0, 7.1, 8.6, 2009). I uninstalled all of those and only reinstalled 2009. I also installed the DAQmx 9.1.1 and Traditional DAQ drivers.

It took quite some time. It did seem to resolve the DAQ problems. However, I am now having problems with a DIFFERENT dll. Now lvanlys.dll is not loading. The error is "Error loading \lvanlys.dll" A dynamic link library (DLL) initialization routine failed.

I have traced the dll to the math functions located here: vi.lib\Analysis\* These are functions like Mean, Linear Coefficients and such. It seems to be a linking problem, not a file problem. A replacement file did not solve this initialization problem.

Any help would be greatly appreciated here.

Member
rajeswari
Posts: 37
0 Kudos

Re: The application failed to initialize properly (0x0000142)

Hello All,

 

Can anyone provide the solution to this error. I am getting the same problem.

 

While restart getting Devenv error and DAQmx vis giving nilvaiu.dll failure and not able to open MAX. DAQmx 9.3.0 installed into my system recently.

 

1. I tried to reinstall all my DAXmx drivers

2. I tried to disable PAE using /execute= alwaysoff /NOPAE

3. I tried to set /maxmem=4096

 

nothing seems to workout for me.

 

My PC is having LAbview 7.1 and Labview 8.6 drivers

Windows XP service pack 2, recently I upgraded my RAM from 1 GB to 2GM and Harddisk memory upgraded to 80GM from 40GB.

 

Thanks In Advance.

 

 

Member
Jonathan_S1
Posts: 137
0 Kudos

Re: The application failed to initialize properly (0x0000142)

[ Edited ]

Hi,

 

Was the system working before you tried to upgrade DAQmx 9.3?  DAQmx 9.3 will not work with LabVIEW 7.1.  The most recent DAQmx that will work with LabVIEW 7.1 is DAQmx 8.9.  Can you uninstall the 9.3 version and install 8.9?  What exactly do you mean by LabVIEW 8.6 drivers?  Do you mean the drivers that shipped with LabVIEW 8.6, or do you mean DAQmx 8.6?

 

Jon S

Applications Engineer
National Instruments