NI Home > Community > NI Discussion Forums

Multifunction DAQ

Showing results for 
Search instead for 
Do you mean 
Reply
Member
Zachmx
Posts: 180
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

Hi BGao,

 

Were you able to try the workaround mentioned above? The newest DAQmx version should allow you to limit the outstanding USB Transfer Request count for your device.

Zach P.

Product Support Engineer | LabVIEW R&D | National Instruments
Member
donald1990
Posts: 6
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

hello i am using windows 7 along with daqmn 9.5.1 and labview 2011 i am using 6009 daq,

i have tried to solve the issue by adding the property node to the acquire the signal.

i have tried adding the the property node after generating code from daq assistant(configured as acquire continous samples of voltage signals ).

but still its not working and showing the same error i have attached the snipseet nad vi also please help,

Am i connecting the property node correctly?

if not where is to add the property node in the vi??

please help

Member
BGao
Posts: 4
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

Hi Zach P.

Thanks for your quick reply.

I tried several things:

First, reinstall the device's USB driver in win7.

Second, add the DAQ channel property: AI.UsbXferReqCount to 1 as per instruction of http://digital.ni.com/public.nsf/allkb/611475F9BE62881E86256FDC0062B1BB?OpenDocument

Third, change the DAQ assistant setting to normal DAQmx code

 

Finally, it works well for several hours. I really do not which is the key reseaon to kill the issue. Anyway, it works.

 

Member
donald1990
Posts: 6
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

That awesome man congratz bgao,

can you upload a sinpset of a vi of acquire signal with the the work around fix actually i am unable to figure out where to add the property node in the code generated along with where to connect it. 

thanks 

Member
donald1990
Posts: 6
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

p.s i have also tried the work around but the daqmx channel property node does not  have an input for sb request count property it only shows error out for the property.

i have attached the snipset dipcting only error out for  input channel usb request count

Member
BGao
Posts: 4
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

[ Edited ]

Hi Donald1990,

Below is a screencopy of my code.

A much more detailed instruction will be available at http://digital.ni.com/public.nsf/allkb/611475F9BE62881E86256FDC0062B1BB?OpenDocument

 

I hope this would be helpful.

 daqmx channel property.jpg

Member
donald1990
Posts: 6
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

hey thanks Bgao,

i will much appreciate and will be thank full if you upload a vi i am still having problem in defining the constant value 1 its not showing me that input

 

Member
BGao
Posts: 4
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

attached

Member
donald1990
Posts: 6
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

Thanks alot man,

 

but no salubrious results =(

still showing the same error -200361,

i dont know when will i ll get rid of it :smileysad:

i am sick of finding solution to it....

Trusted Enthusiast
John_P1
Posts: 2,489
0 Kudos

Re: Getting Error -200361 after start/stop of the data acquisition (USB-6009), DAQmx 9.2.2

Hi Donald,

 

From what you've posted so far it looks like you're reading from the property, you need to write to it and set the XferReqCount to 1 (you can right-click the property and select "Change All to Write") . You also need to do this before you start the task (in your first image the property was placed after DAQmx Start).

 

However, BGao's example does do this, so if you're running his example and still get the error then it sounds like your error might not have the same root cause.  Can you post the code you are running and confirm that you are indeed receiving error -200361?  This error indicates an on-board FIFO overflow--the most common cause for this that I have seen is the Windows 7 USB issue (which the workaround in this thread is intended to solve), but if for some other reason the computer is not keeping up with the USB transfers you might also see the same error message.  Are you using an external hub or do you have any other USB devices attached to the same computer?  Which revision of USB is the port on your computer (i.e. is it USB 3.0?).

 

 

Best Regards,

John Passiak