NI Home > Community > NI Discussion Forums

Measurement Studio for VC++

Showing results for 
Search instead for 
Do you mean 
Reply
Member
vijay82
Posts: 2
0 Kudos

linking errors while building C examples in VC 6.0

I am using NI PCI5112 DIGITIZER CARD  with NISCOPE 3.6 on WIDOWS XP OS. I am trying to build the c examples that are supplied along with the driver software in VC++ 6.0. I have included the header files in the following folders,

D:\Program Files\IVI Foundation\IVI\Include

D:\Program Files\IVI Foundation\VISA\WinNT\include

D:\Documents and Settings\All Users\Documents\National Instruments\NI-SCOPE\examples\c\common

I have also included the library files in the following folders:

D:\Program Files\IVI Foundation\VISA\WinNT\lib

D:\PROGRAM FILES\IVI FOUNDATION\IVI\LIB

 

 

 

Whenever I am trying to build any example c source code, I encounter the following linking error.

 

 

 

--------------------Configuration: vijay1 - Win32 Debug--------------------

Linking...

MultiRecord.obj : error LNK2001: unresolved external symbol _niScope_GenericMultiRecord@0

MultiRecord.obj : error LNK2001: unresolved external symbol _asciiPlot@8

Debug/vijay1.exe : fatal error LNK1120: 2 unresolved externals

Error executing link.exe.

 

 

 

vijay1.exe - 3 error(s), 0 warning(s)

 

 

you are kindly requested to extend your guidance in resolving this problem.

Member
蔚蓝的天1280
Posts: 27
0 Kudos

回复: linking errors while building C examples in VC 6.0

Hi,

I have encountered a simila problem. 

I call IVI CLASS Driver-functions in VC6.0 without no compiling errors.Howerer,there is a fatal,unknown link-error,

I include the same .h files and .lib files.

In my opinion,you should include revalent ni-files.

Active Participant
D_Biel
Posts: 676
0 Kudos

回复: linking errors while building C examples in VC 6.0

Try adding the appropriate source files from C:\Users\Public\Documents\National Instruments\NI-SCOPE\examples\c\common. With the errors posted by vijay, I would suggest adding asciiplot.c and GenericMultiRecord.c.

National Instruments
Product Support Engineer
Member
蔚蓝的天1280
Posts: 27
0 Kudos

回复: linking errors while building C examples in VC 6.0

Thanks very much!

But there is a problem that I didn't explain in details.

My Test programs is that I call DMM IVI-CLASS Drivers in VC 6.0. However, there is a fatal error LINK1000:unknown

error.

Can you help me solve it?

The contrete problem IN the Attachment.

Thanks again!