NI Home > Community > NI Discussion Forums

Measurement Studio for .NET Languages

Showing results for 
Search instead for 
Do you mean 
Reply
Member
pbrand
Posts: 12
0 Kudos

Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

We have a web site that uses the NationalInstruments.UI.Webforms.Scattergraph control.  We have run into a problem while testing with Windows Server 2008 R2.  

 

 

Configuration Error
 
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
Parser Error Message: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a' or one of its dependencies. The system cannot find the file specified.
Source Error: 
Line 38:  <add assembly="System.Drawing.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
Line 39:  <add assembly="NationalInstruments.Common, Version=8.6.35.419, Culture=neutral, PublicKeyToken=18cbae0f9955702a"/>
Line 40:  <add assembly="NationalInstruments.UI, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a"/>
Line 41:  <add assembly="NationalInstruments.UI.WebForms, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a"/>
Line 42: </assemblies>

 

 

I have checked and all the NI files are in the GAC and there are in the folder where the website is located.  Why is this file not able to be found?  The install works fine in xp, vista, 7, 2003 and 2008.  Its just having a problem with 2008 R2.  Any help or insight would be appreciated.
Thanks.
Member
Christopher_T.
Posts: 163
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi pbrand,

 

Do you see an assembly binding is turned off warning below the configuration error? If so, follow the instructions to enable it, which should give you more error information.

 

Thank you!

Chris T.
Applications Engineer
National Instruments
Member
pbrand
Posts: 12
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

I turned on assembly binding logging.  Below is the log:

 

 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'NationalInstruments.UI.WebForms, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a' could not be loaded.
=== Pre-bind state information ===
LOG: User = IIS APPPOOL\Classic .NET AppPool
LOG: DisplayName = NationalInstruments.UI.WebForms, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a
 (Fully-specified)
LOG: Appbase = file:///C:/Program Files (x86)/Ludlum Measurements, Inc/Model 375 Supervisor Service/
LOG: Initial PrivatePath = C:\Program Files (x86)\Ludlum Measurements, Inc\Model 375 Supervisor Service\bin
Calling assembly : (Unknown).
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Program Files (x86)\Ludlum Measurements, Inc\Model 375 Supervisor Service\web.config
LOG: Using host configuration file: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Aspnet.config
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v2.0.50727\config\machine.config.
LOG: Post-policy reference: NationalInstruments.UI.WebForms, Version=8.6.35.465, Culture=neutral, PublicKeyToken=18cbae0f9955702a
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/Temporary ASP.NET Files/areamonitor/25db8d6a/3f1aff7/NationalInstruments.UI.WebForms.DLL.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/Temporary ASP.NET Files/areamonitor/25db8d6a/3f1aff7/NationalInstruments.UI.WebForms/NationalInstruments.UI.WebForms.DLL.
LOG: Attempting download of new URL file:///C:/Program Files (x86)/Ludlum Measurements, Inc/Model 375 Supervisor Service/bin/NationalInstruments.UI.WebForms.DLL.
LOG: Attempting download of new URL file:///C:/Program Files (x86)/Ludlum Measurements, Inc/Model 375 Supervisor Service/bin/NationalInstruments.UI.WebForms/NationalInstruments.UI.WebForms.DLL.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/Temporary ASP.NET Files/areamonitor/25db8d6a/3f1aff7/NationalInstruments.UI.WebForms.EXE.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/Temporary ASP.NET Files/areamonitor/25db8d6a/3f1aff7/NationalInstruments.UI.WebForms/NationalInstruments.UI.WebForms.EXE.
LOG: Attempting download of new URL file:///C:/Program Files (x86)/Ludlum Measurements, Inc/Model 375 Supervisor Service/bin/NationalInstruments.UI.WebForms.EXE.
LOG: Attempting download of new URL file:///C:/Program Files (x86)/Ludlum Measurements, Inc/Model 375 Supervisor Service/bin/NationalInstruments.UI.WebForms/NationalInstruments.UI.WebForms.EXE.

 

Member
Christopher_T.
Posts: 163
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi pbrand,

 

It definitely is strange that it is working on all but one OS, and I presume all the OS's have the same deployment on each?

 

We'll look into the matter and get back to you!

 

Thank you!

Chris T.
Applications Engineer
National Instruments
Member
pbrand
Posts: 12
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Yes, is the same deployment on each OS.  Thanks for looking into this.

Member
Christopher_T.
Posts: 163
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi pbrand,

 

Could you perhaps produce a fusion log?

 

Instructions can be found here:

http://decibel.ni.com/content/people/nickb/blog/2009/06/16/using-fusion-logs-to-debug-net-assembly-b...

 

It will generate files that you can just zip up and send, also a list of all the assemblies and dlls in the publishing folder as well as your web.config. Now, we understand that you might not want to post that on the forums. Instead can you upload the information to our ftp which will keep your files behind our firewall so that it is safe.

 

Our FTP:

ftp://ftp.ni.com/incoming

 

Let us know when it is uploaded!

 

Thank you!

Chris T.
Applications Engineer
National Instruments
Member
pbrand
Posts: 12
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi Christopher,

 

I have uploaded the file to the ftp site.  Filename is pbrand_fusionlog.zip.

Thanks!

Member
Christopher_T.
Posts: 163
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi pbrand,

 

Thank you!

 

We are currently looking into the issue.

 

Chris T.
Applications Engineer
National Instruments
Member
Christopher_T.
Posts: 163
0 Kudos

Re: Could not load file or assembly 'NationalInstruments.UI, Version=8.6.35.465'. The system cannot find the file specified

Hi pbrand,

 

After looking into the fusion logs, it looks like a conflict of 64 bit to 32 bit applications. Pre-Measurement Studio 2009 assemblies do not have 32-bit support and it looks like IIS is causing the 32-bit only assemblies to be run in 64-bit mode. 

 

Try setting the "Enable 32-bit Applications" property in the application pool.

 

We don't have a KB for it but there is a screen shot of this in this link:

http://support.softartisans.com/kbview_1213.aspx 

 

Hope this helps!

Chris T.
Applications Engineer
National Instruments