NI Home > Community > NI Discussion Forums

Measure

Reply
Member
Puzzlegal
Posts: 1
0 Kudos

Error -10899 occurred at AI group config

Hi,
 
I encountered this error (Error -10899 occurred at AI group config) when i was trying to measure my signals from the data acquisition card. Any advice?
 
Thanks!
 
 
Member
Hani R
Posts: 135
0 Kudos

Re: Error -10899 occurred at AI group config

Hi Puzzlegal,

Make sure you are logged in as an administrator before running your program.  If you are sure you have administrator privileges on your PC, we will need to troubleshoot further. 

I have a few questions for you about your system.  What DAQ card are you using?  What version of the NI Traditional DAQ driver do you have installed?  Were you ever able to acquire signals with your DAQ card using this program?  Are you able to test your channel in Measurement and Automation Explorer?

Keep me posted. 



Best Regards

Hani R.
Applications Engineer
National Instruments
Member
Gogy82
Posts: 2
0 Kudos

Re: Error -10899 occurred at AI group config

Hello,

I have the same problem for Traditional (legacy).

I had old computer with AT-MIO 16E-10 on ISA and I made some application in VB6 to measure Input Analog signal 0-10V (NI-DAQ 6.1).

Then I focused with some problems related to this old computer and I decided to buy new computer and PCI-MIO 16XE-50 card (NI-DAQ 7.1).

I installed and tested with Measurement & Automation explorer and everything was fine, but while starting my application I got error message on startup "cannot found nidaq32.dll". After this I was searching and reading forums and found that I need to install latest NI-DAQ.

I've installeed Traditional 7.4.4. and then I couln't get any test panel button enabled for my device in Traditional but it is enabled only in DAQmx.

How to solve this to get it working with Traditional? I am getting Error -10899 occurred at AI group config

If you need any other information, please ask...

Thank you
Gogy
Member
Hani R
Posts: 135
0 Kudos

Re: Error -10899 occurred at AI group config

Hi Gogy,

The error is usually caused by lack of administrative privileges on a Windows login account.  Sometimes you may be able to develop your application in one account, but unable to run the program.  Make sure that you have full administrative privileges on your Windows login account and that all NI folders are shared between different accounts. 


Best Regards

Hani R.
Applications Engineer
National Instruments
Member
eurotherm2404
Posts: 3
0 Kudos

Re: Error -10899 occurred at AI group config

 

I'm trying to test my traditional NI-DAQ virtual channel and when I try to run the test I get 'error 10899 occurred at Al Group Config.'  I'm running windows XP with a PCI NI 4351 and I'm logged in as administrator. It says that the channel is valid, any ideas?