NI Home > Community > NI Discussion Forums

LabWindows/CVI

Reply
Member
CviUser2003
Posts: 86
0 Kudos

viOpen("GPIB0::2::INSTR") = "A code library required by VISA could not be located or loaded"

I've parsed through a lot of posts on this forum, and on google, and I got the same response: Re-install VISA.

 

http://forums.ni.com/t5/LabVIEW/what-is-gpib-error-code-1073807202-VISA-or-a-code-library/m-p/920473...

 

http://forums.ni.com/t5/LabVIEW/VISA-Error-1073807202-Pls-help/m-p/1461758/highlight/true#M556870

 

http://forums.ni.com/t5/LabVIEW/VISA-error/m-p/23418/highlight/true#M16079

 

Unfortunately, re-installing the latest version of NI-VISA didn't work for me.

 

I am running in a Windows XP box, to control three old HP6654 power supplies.  They are GPIB0::0::INSTR, GPIB0::1::INSTR, and GPIB0::2::INSTR.  The first device to initialize is GPIB0::2::INSTR.

 

MAX is talking to the device, but I don't know if it is using VISA or not.  We are able to Query "*ISDN?".

 

NI Spy (NI IO Trace) shows viOpenDefaultRM() runs fine (returns 0), but as soon as viOpen( 0x02A08970, "GPIB0::2::INSTR", 0,0, 0x0000000), it returns a status of 0xBFFF009E = "A code library required by VISA could not be located or loaded"

 

I've tried recompiling the CVI 8.5 source with CVI 9.0.1 thinking DLL issues, but I got the same error (0xBFFF009E).

 

 

Note: this machine used to work with these supplies, back in March 2012.  Then a user installed the drivers for a USB-to-GPIB (by ICS) back around April timeframe, and my application's logs indicate that it stopped working from that point on.  He's uninstalled the driver (and re-installed it back, then I uninstalled it), since the device is no longer on that computer, but we believe it corrupted the VISA environment, but cannot be recovered.

 

- I've tried to install the latest versions of NI-GPIB and NI-VISA, and Device Drivers 2007, but got the same error (0xBFFF009E). 

 

I'm trying to download (Device Drivers 2012 Aug) now to see if this works, but I don't think it will.

 

 

Any help is appreciated.

 

Thanks.

Member
CviUser2003
Posts: 86
0 Kudos

Re: viOpen("GPIB0::2::INSTR") = "A code library required by VISA could not be located or loaded"

I couldn't un-install all the NI device drivers in the machine, because there were a lot of applications that were dependent on those device drivers.

 

I couldn't un-install just the NI-VISA, because a few in-house applications still required it, and forces an uninstall of those applications. 

 

I installed DCD_Aug2012 drivers, at first with the default check-offs, but it still didn't work.

 

I forced a re-install of most of the drivers, and it finally worked!