NI Home > Community > NI Discussion Forums
Reply
Active Participant
Ian.W
Posts: 357
0 Kudos
Accepted Solution

Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

I have a user who reports being unable to launch our app under Windows 8.1. The message is:

 

"The procedure entry point HttpOpenDependencyHandle could not be located in the dynamic link library C:\Windows\System32\urlmon.dll"

 

My suspicion is that it is a Win8.1 issue, given the reports here, but I'm also an worried it is a deliberate change by Microsoft.

 

Is anyone else seeing this? Any ideas on the cause or solution?

 

Thanks,

Ian

 

Member
Basil-B
Posts: 69
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Hi Ian,

 

What application is this that Windows 8.1 is not able to open?

 

Regards,
Basil
Applications Engineering
National Instruments
Active Participant
Ian.W
Posts: 357
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Basil,

 

It is our own app, built with CVI 2009 (9.1.1). The installer seems to run fine but when the program is launched it gives this error.

 

The program uses the CVI Internet and XML Libraries, plus ActiveX to export data to Excel and PowerPoint.

 

Looks like I'll need to fire up a VM with Windows 8.1 and reproduce it myself to make much progress with it.

 

--Ian

Member
Basil-B
Posts: 69
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

That would be a good idea. Did the customer have multiple versions of CVI installed? If so it could simply be an issue of which directory the DLL is in. 

Regards,
Basil
Applications Engineering
National Instruments
Active Participant
Ian.W
Posts: 357
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Well, the plot thickens. I have been able to replicate a similar issue with the Windows 8.1 Preview (32 bit) inside VirtualBox.

 

However when our app is launched, it gives a different error message before terminating: "The ordinal 289 could not be located in the dynamic link library C:\Program Files\{CompanyName}\{AppName}\WININET.dll." (The customer who reported the original issue was running Win 8.1 64 bit, so that may be why the error message is different.)

 

The common issue with this and the other message seems to be the inclusion of the NI Internet Library features.  I tried building the sample XML project that ships with CVI (no internet functionality) and it installs and runs fine in the Win 8.1 environment.

 

We did not see this problem with Windows 8.0.

 

My conclusion is that the Internet Library that we're using with CVI 2009 (9.1.1) has some incompatibility with Windows 8.1. The question is how to get around it.

  • Can we just update the DLLs we're using?  
  • Would updating to CVI 2013 solve it? (Has anyone deployed apps using the CVI Internet Library to Windows 8.1?)

Thanks in advance for any tips.

 

--Ian

Active Participant
Ian.W
Posts: 357
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

I have just tested and confirmed for myself in a VM that the exact same app that generates the error runs fine in Windows 8.0.

 

So there is definitely a Windows 8.1 vs 8.0 compatibility problem.

 

--Ian

Active Participant
Ian.W
Posts: 357
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

The problem still exists with Windows 8.1 RTM released today to MSDN subscribers.

 

My question to anyone (NI?) using a more recent version of CVI:

  • Have you been able to run an app that uses the Internet Library under Windows 8.1?
  • Is there a newer SDK that would solve the problem?

Thanks in advance for any help.

 

--Ian

Member
Basil-B
Posts: 69
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Hi Ian,

 

I am filing a bug report on it with NI and from there the Product Support Engineer might decide to inform Microsoft about it, since it seems like something on their end. I will let you know if there is anything else we can do.

 

 

Regards,
Basil
Applications Engineering
National Instruments
Active Participant
Ian.W
Posts: 357
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Thank you very much, Basil.

 

(By the way I see that I did not directly answer your earlier hypothesis about multiple versions of CVI. The problem occurs after deploying just our one app to a clean install of just Windows 8.1, so multiple versions of CVI or the RTE are not the issue. )

 

--Ian

Active Participant
D_Biel
Posts: 676
0 Kudos

Re: Windows 8.1: Entry Point Not Found - HttpOpenDependencyHandle

Ian,

 

I have installed Win 8.1 (x64) RTM and CVI 9.1.1. However, I cannot reproduce either error with an internet library example. Are you able to reproduce this with any of the samples? If not, are you able to send me your project to test it on my system? If you can, I have sent you a private message with instructions on how to send me project.

National Instruments
Product Support Engineer