NI Home > Community > NI Discussion Forums

LabVIEW

Showing results for 
Search instead for 
Do you mean 
Reply
Member
PEG2
Posts: 6
0 Kudos

OPCサーバとPLCのリンク

 PC上のNI OPCサーバ2009とPLC:三菱Q03UDEをEthernet接続したいのですが、データリンクができずに困っております。始めて使用するためつまらない設定ミスがあるものと思われますが、今のところ原因の切り分けができておりません。お知恵を拝借したく存じます。

 OPCサーバーのヘルプにある三菱QシリーズのページではEthernetモジュール付きの説明がなされておりますが、当該PLCはEthernetポート付きのPCモジュールで構成されているため、PLC設定を私の方で適宜読み替えて行いました。自分としては、この部分の設定ミスである可能性が高いと考えていますが、確実ではありません。

 

 現状は以下の通りです。

 

ハードウェア構成

PC:Windows7搭載PC+ NI OPCサーバー2009、ウィルス対策ソフトとファイヤーウォールはOFF

PLC:三菱Q03UDE

接続:ルータを介さず、クロスリンクEthernetケーブルで直接接続。pingが通ることだけは確認済

 

設定:

PC: IPアドレス192.168.3.1、サブネット255.255.255.0、ゲートウェイ、DNSは空

PLC:別のPCとUSB接続し、設定ソフトで以下のように設定

  IPアドレス192.168.3.2、サブネット255.255.255.0、ルータは空で設定できなかったため192.168.3.1を入力

  バイナリデータ設定、RUN中書込あり

  オープン設定は以下のようにしました。

   UDP 接続方式:ソケット接続 自局ポート番号:5010(decimal) 5000から5009番が設定できない旨

       メッセージが出たため代替え 接続IP:255.255.255.255 交信相:FFFF(HEX)

   TCP/IP 接続方式:ソケット接続 オープンシステム:unpassive 自局ポート番号:5011(decimal)

 

OPCサーバー設定

 チャネル設定 ドライバー:Mitsubishi Ethernet ネットワーク:default

  デバイス設定 モデル:Q Series デバイスID: 192.168.3.2:N0:255  IPプロトコル:UDP ポート番号5010

 タグ設定 名前:適当につけている アドレス:W200他いくつか試した Data type: DWord(他も試した)

 

表記していない設定値はデフォルトのままです。 

 

この状態で、OPCクイッククライアントを起動しました。View-Diagnostics-Channelで確認しますと、PLCから

全くデータが戻ってきません。OPCサーバーのメッセージウィンドウに「PLCが応答しない」とのメッセージが出ます。

 

以上のような状況です。よろしくお願いいたします。

 

 

 

Knight of NI
RavensFan
Posts: 16,070
0 Kudos

Re: OPCサーバとPLCのリンク

Please post in English on the LabVIEW board, or post your question on this board.  You will get a better response.
Member
PEG2
Posts: 6
0 Kudos

Re: OPCサーバとPLCのリンク

Sorry. I have sent a message to the wrong discussion board. Thank you.