NI Home > Community > NI Discussion Forums

LabVIEW

Reply
Member
Rick_F_Foster
Posts: 57
0 Kudos
Accepted Solution

GPIB and Desktop RT

I am running the following:

 

Desktop Labview Real Time 11.0

NI-VISA Server 5.1

 

and am using an NI PCI-GPIB card to connect to a couple of different pieces of lab equipment.

 

When I connect to this remote system from another workstation using MAX, I do see GPIB0 (PCI-GPIB) under devices and Interfaces on the RT machine, but I cannot figure out how to see the GPIB instruments that are connected to the bus.

 

I don't think it is a electrical problem on the bus because when I boot the workstation into windows instead of RT, I can see the instruments just fine using Max on that machine.

 

Rick

 

PS: The workstation I use to connect to the RT machine remotely runs a current version of Labview

 

 

Rick Foster
MIT Kavli Institute for Astrophysics and Space Research
Member
Eric_LV
Posts: 83
0 Kudos

Re: GPIB and Desktop RT

Does your Real-Time PC have a version of NI-488.2 drivers on it?  You will need them to use a GPIB device.  

Regards,

Eric L.
Applications Engineer
National Instruments
Member
Rick_F_Foster
Posts: 57
0 Kudos

Re: GPIB and Desktop RT

Yes.

 

NI-488.2 RT 2.8.1

 

 

Rick Foster
MIT Kavli Institute for Astrophysics and Space Research
Member
Eric_LV
Posts: 83
0 Kudos

Re: GPIB and Desktop RT

So you already have the first step done but you might want to try out the next steps in this tutorial, let me know what the results are.

 

http://digital.ni.com/public.nsf/allkb/D703FC483D57D1F98625709A0045FAD4?OpenDocument

Regards,

Eric L.
Applications Engineer
National Instruments
Member
Rick_F_Foster
Posts: 57
0 Kudos

Re: GPIB and Desktop RT

The current VISA Interactive Control layout is a bit differenent from the tutorial.

 

I do see the instruments now, but they are listed under localhost and I get an error when I try to list them on the remote machine that the GPIB controller is installed in.

 

 Capture1.JPG

 

Capture2.JPG

 

I can now access the instruments in my code, but this Localhost versus Remote machine bit is confusing.

 

Rick

 

 

Rick Foster
MIT Kavli Institute for Astrophysics and Space Research
Member
Eric_LV
Posts: 83
0 Kudos

Re: GPIB and Desktop RT

I am not sure if this is the case for you but often when someone can use a device in their code but cannot properly see it in Measurement and Automation explorer it is due to an IP address misconfiguration.  I would check and make sure your RT PC is on the same subnet as your host and see if that does not solve the issue.  

Regards,

Eric L.
Applications Engineer
National Instruments
Member
Rick_F_Foster
Posts: 57
0 Kudos

Re: GPIB and Desktop RT

In the snippets above, I blacked out the IP address, but all the machines (development, target anf RT) are all on the same subnet.

Rick Foster
MIT Kavli Institute for Astrophysics and Space Research
Member
Eric_LV
Posts: 83
0 Kudos

Re: GPIB and Desktop RT

I have a couple fo things for you to try out.  First, drop down your RT PC in Remote Systems in MAX, drop down the Software tab and click on NI VISA.  At the bottom of the screen there should be a tab called VISA Options, under VISA Server>> Security add an asterisk (*) to the list of remote addresses.  This will allow any system to access the VISA server on your RT PC which may have been preventing your Host from accessing the VISA server.  

 

Second, Go to Tools>>NI VISA>> VISA Options and select Remote under General Settings.  Make sure your RT PC is selected in the list on the Remote tab.  After that close and reopen MAx and let me know if anything works differently.  

Regards,

Eric L.
Applications Engineer
National Instruments
Member
Rick_F_Foster
Posts: 57
0 Kudos

Re: GPIB and Desktop RT

No changes ... I had already done this :smileyhappy:

 

 

Rick Foster
MIT Kavli Institute for Astrophysics and Space Research
Member
Eric_LV
Posts: 83

Re: GPIB and Desktop RT

Hey Rick,

 

I've done some testing and it seems this is just how GPIB devices appear on Real-Time targets in VISA Interactive Control.  It might seem a little confusing but yes they are supposed appear under local host.  It sounds like aside from the confusion there does not seem to be an actual problem, am I correct?  

Regards,

Eric L.
Applications Engineer
National Instruments