Showing results for 
Search instead for 
Did you mean: 
Reply

Explanation of labview program and errors occurred for KE6485 picoammeter

Highlighted

Explanation of labview program and errors occurred for KE6485 picoammeter

Hi,

 

I am new to LabView and i am tasked to measure current using a KE6485 Picoammeter. I tried searching the forums and discussion board and i manage to find a labview program which measured the current. 

I tried running the program, but it showed two errors.

Primary Error: Driver status: (Hex 0xBFFA0010) Invalid value for parameter or property.

Secondary Error: (Hex 0xBFFC0004) Parameter 4 out of range, or error occurred while setting Parameter 4. 

 

Can somebody kindly explain to me the errors and if possible, can you also explain exactly what does the LabView program does. I attached a copy of the labview program.

 

Thank you so much.

0 Kudos
Message 1 of 4 (80 Views)
Reply
0 Kudos

Re: Explanation of labview program and errors occurred for KE6485 picoammeter

[ Edited ]

Hi Matt,

 

unfortunately all subVIs are missing so we cannot examine the source of your errors.

I guess you used some driver from IDNet but to be really sure you need to attach those subVIs too!

(Create a source distribution for your main VI to include all subVIs…)


Can you use a different tool/program to communicate with your Ammeter to make sure the cabling is ok?

Best regards,
GerdW
CLAD, using 2009SP1 + LV2011SP1 + LV2014SP1 (+ LV2016 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink
0 Kudos
Message 2 of 4 (50 Views)
Reply
0 Kudos

Re: Explanation of labview program and errors occurred for KE6485 picoammeter

Hi GerdW,

 

I tried testing the ammeter, and it is working fine. Regarding the subVIs, i'm having trouble with it too. That's because i copy the whole VI from one of the discussion board and i'm trying to figure out what it does. 

Is there any way that i can create a LabView VI for KE6485 Picoammeter by myself? All i need is just to ensure that the Picoammeter is able to measure current from an external measuring device.

 

Thanks.

Matt_tt

0 Kudos
Message 3 of 4 (34 Views)
Reply
0 Kudos

Re: Explanation of labview program and errors occurred for KE6485 picoammeter

[ Edited ]

Hi matt,

 

Is there any way that i can create a LabView VI for KE6485 Picoammeter by myself?

Yes, sure! LabVIEW is a programming language! Smiley Very Happy

 

I see two options:
- check the IDNet to find suitable device drivers. Then try to communicate with your device. In case of problems check the manual to ensure the correct commands are used in the driver VIs.

- create your own device driver VIs using VISA. To do so you should read the manual and find the commands you want/have to use…

Best regards,
GerdW
CLAD, using 2009SP1 + LV2011SP1 + LV2014SP1 (+ LV2016 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink
0 Kudos
Message 4 of 4 (27 Views)
Reply
0 Kudos