Showing results for 
Search instead for 
Did you mean: 
Reply

Can't Connect to Network Stream in startup.rtexe

Can't Connect to Network Stream in startup.rtexe

Hello,

 

I have encountered a rather frustrating issue. I have developed an architecture that depends on network streams to connect my RT application (hosted on a cRIO) to several windows clients. Everything worked seamlessly when I was running the RT Host VI from my Labview project. However, when I tried to deploy the RT application as a startup vi on the cRIO (as startup.rtexe). I could no longer establish a connection to the nettwork streams.

 

I have tried adjusting the context name of the network stream path to "startup.rtexe", but this did not help.

 

Can anybody help me?

 

THANKS!

0 Kudos
Message 1 of 4 (318 Views)
Reply
0 Kudos

Re: Can't Connect to Network Stream in startup.rtexe

Hi RyanEwart,

 

Do you get some error code or a error message?

 

Carmen C.

0 Kudos
Message 2 of 4 (284 Views)
Reply
0 Kudos

Re: Can't Connect to Network Stream in startup.rtexe

I've been meaning to post my results. The error actually entered the chain prior to the Network Streams. It boiled down to a rookie mistake:

Don't use 'Value' Property nodes in a real-time application! When the RT application is deployed, no front panel is loaded and these type of property nodes will error.

 

Thanks!

0 Kudos
Message 3 of 4 (280 Views)
Reply
0 Kudos

Re: Can't Connect to Network Stream in startup.rtexe

Hi RyanEwart,

 

I'm glad to hear that this is already solved!

 

Best,

 

Carmen C.

0 Kudos
Message 4 of 4 (277 Views)
Reply
0 Kudos