NI Home > Community > NI Discussion Forums

LabVIEW

Showing results for 
Search instead for 
Do you mean 
Reply
Member
drog
Posts: 22

Re: Arduino+LabVIEW

I downloaded your attachment from your post of the 14th and it ran fine on my computer (XP, LabVIEW 2009). In my case the Arduino Uno mapped to Com4.

 

Does your com port appear in MAX? (Measurement and Automation Explorer). Open MAX and in the Configuration panel on the left tunnel down through My System->Devices and Interfaces -> Serial & Parallel. Clicking on the Com port will give you further info as to the resource name, the Alias and if it is working properly as well as troubleshooting info.

 

If not, have you installed the Arduino USB drivers in windows? Have a look at the Windows device manager and make sure that the USB port is working. Drivers are available in the drivers folder of the Arduino development suite.

 

Cheers

Member
Chintha
Posts: 33
0 Kudos

Re: Arduino+LabVIEW

Hi i am getting the example of the below link ,, the  Firmata example...

It is just reading the temp values of Lm35 which is conncted to Analog 0 pin.I have added Wave form generator also and able to display it succcessfully,,

My question is how to read the serial port data ie, temperature values in deg centigrade and plot it ,,,

the only aim of my project...

 

Thanks 

Member
Chintha
Posts: 33
0 Kudos

Re: Arduino+LabVIEW

Hi i am getting the example of the below link ,, the  Firmata example...

http://code.google.com/p/labviewduino/

It is just reading the temp values of Lm35 which is conncted to Analog 0 pin.I have added Wave form generator also to front panel of labviewduino-v1.0.0.127\Firmata-example-AI.vi,, and able to display it succcessfully,,

My question is how to read the serial port data ie, temperature values in deg centigrade and plot it ,,,

the only aim of my project...

 

Thanks 

Member
Chintha
Posts: 33
0 Kudos

Re: Arduino+LabVIEW

Hello all, The good thing is that even though no replies from anybody ,,i am getting used to Labview.. Plz respond even to ths post atleast.. I am attaching Whole project. Here is the brief description: I am trying to read temperature sensor data using Visa.The html file describes every thing related to arduino sketch and required vi's. There is a jpg which shows the error i am getting . I tried every possible solution we have decribed,, no problem with visa serial configuration settings .... Also see step3 of html ,, how to connect intensity chart,,,what are the blocks before that block,,, PlZ plZ respond ,,,,,,,,,,,,,,,,,,,,,, Plz............. Plz....................
Trusted Enthusiast
Coq_Rouge
Posts: 2,189
0 Kudos

Re: Arduino+LabVIEW

I can so no Attachments in your last posting.....



Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
(Sorry no Labview "brag list" so far)
Active Participant
NIquist
Posts: 1,419

Re: Arduino+LabVIEW


LOYOLA wrote:
 PlZ plZ respond ,,,,,,,,,,,,,,,,,,,,,, Plz............. Plz....................

Plz, plz, PLZZZZ don't plead.  It's unhelpful and unprofessional. 

 

  Learn how to attach items to your posts.  You keep saying something is attached but nothing is there so we can't help.

  You've already effectively closed this thread by accepting a solution.  Most people skip over those.  You may need to start a new thread for this problem.

Using LabVIEW: 7.1.1, 8.5.1 & 2013
Member
Chintha
Posts: 33
0 Kudos

Re: Arduino+LabVIEW

Here is the attachment i am talking about

Member
JohnCS
Posts: 95
0 Kudos

Re: Arduino+LabVIEW

A link to the files you seek is found at the bottom of this html page that was referred to in the web page that you attached. page 2

 

The link to the VIs is

 

Arduino LabVIEW.zip   

 

 

JohnCS

 

 

 

 


Member
drog
Posts: 22
0 Kudos

Re: Arduino+LabVIEW

Well... I am not familiar with Firmata so I can't provide help with this, but I am confused. You say that you are getting readings from analog 0 using "firmata" but then you say its not working because you are getting a VISA error. If the "firmata" version is working can you just add a loop to gather the data into an array and graph it/save it? I think this is the goal for your project. You can also do any conversion/processing in the loop.

 

I can't open your code as I am running version 2009 and your code is 2010. I looked at your jpg and I see you are running the eval version. I don't know if this may cause VISA issues. I don't see anything on NI's website to suggest so. Also in the image background you have a number of coercion dots. I can't see enough of the code to see if this is a problem but this should be investigated as well.

 

Member
JohnCS
Posts: 95
0 Kudos

Re: Arduino+LabVIEW

The recurring error you have been getting:

 

Error -1073807360 occurred at Property Node (arg 4) in VISA Configure Serial Port (Instr).vi->SerialArduinoTempSensor.vi

 

The error is in argument 4. Argument 4 is SerialSettings:smileyfrustrated:topBit. You have the StopBit set to 1. The default control stop bits defaults to  10 = 1.0.  The value 1 is out of range. You need to set these correctly. Put 10 in the constant if you want 1.0 bits.

 

BTW, you have the parity set to 8. This will cause the parity to be Space Parity. Normally Arduinos use no parity so set this to 0.

 

The stop bits control is a ring control and the parity control is an enum. You must enter the correct value that corresponds to the desired item in the control's list.

 

Your Firmata example works because the serial port is set up correctly.

 

You have three separate threads running with what appears to be the same topic. I notice you just started another one. Please use only one thread.

 

JohnCS