NI Home > Community > NI Discussion Forums

LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Reply
Member
JernejPerhavc
Posts: 12
0 Kudos

Re: LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

Hi All!

I have the same problem as
Herbert had on this forum.... but there was no reply to his question.... if anybody know the anwser, i will be very gratefull. So here is his message copy/pasted:

I'm trying to debug some NXT examples on LV 8.5 such as the Basic Chart.vi using the debug button in the NXT terminal (as described in the example)

But everytime I try this, I'm getting this error message:
Error 1003 occurred at Invoke Node in NXTToolkit.CompileOrCancel.vi->NXTToolkit.TargetAgent.vi

Possible reason(s):

LabVIEW:  The VI is not executable. Most likely the VI is broken or one of its subVIs cannot be located.  Open the VI in LabVIEW using File>>Open and verify that it is runnable.

Method Name: Run VI

VI Path: C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit\gcompiler\Backend.LEGO\NXT.Compiler.Core.vi

Jernej
Member
John Smith
Posts: 1
0 Kudos

Re: LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

I had the same problem, so here's what I did:

Download the LabVIEW 8.5 NXT toolkit patch to your computer.  I put it on my desktop.  Browse in the patch to the Labview 8.5 folder.  Keep opening folders after the Labview 8.5 folder until you get to the first one with more than one folder in it.  You'll have to forgive me, I'm at a different computer right now and cannot be more specific.  I think you get down to the "addons" folder.  There will be about three folders in there.  Copy and paste them into your NXTToolkit folder on your harddrive which I think is at: C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit.  I think I then had to mass compile the thing again using the instructions found in the Getting Started Document for the Labview 8.5 toolkit.  After that, it worked! 

Good Luck!

Member
MarcC
Posts: 131
0 Kudos

Re : LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

Hi all,

I using labVIEW to control Lego NXT. Previously I was working on a MAC OS 10.4 ppc and all was fine. Now I have a new Intel dual core with MAC OS 10.5. And here is the problem, the fantom.framework does not seem to be compatible with Mac Intel. I tried to run labVIEW with Rosetta but in this case the Bluetooth applications do not work.

I really need to make it work so I'm looking for solutions! Is it possible to get the fantom.framework compiled for Mac Intel?

Thanks for the reaply

Marc
Member
JamesB.
Posts: 120
0 Kudos

Re: Re : LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

MarcC --

The first release of the Fantom framework was not build for Intel-based Macs.  Version 1.0 (which you apparently have) only supports them through Rosetta; version 1.1 runs natively on "Mactels."  Since you've also moved to Leopard (Mac OS X 10.5), though, you'll need the latest patch for 1.1 to prevent problems downloading firmware.

You can download the new driver from LEGO's website: http://mindstorms.lego.com/support/updates/

Hope that helps!
------
James Blair
NI R&D
Member
MarcC
Posts: 131
0 Kudos

Re : LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

That's it!

Thanks for help, now it works fine. I downloaded "Mac OS 10.5 (Leopard) Firmware Fix".

Again thanks for answering to this basic question.
Member
Easymac
Posts: 1
0 Kudos

Re: LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

Hi,
I am running Labview 8.2 with the LEGO mindstorm tool kit. My hardware is a macbook pro with 10.4 Labview is running fine, everything is compiled and running on rosette, but whenever i try to open the nxt terminal, Labview quits. I have reinstalled Labview twice and the NXT tool kit three times, but the same problem occurs. ?
Member
janus
Posts: 5
0 Kudos

LabVIEW 8.5 NXT toolkit patch?

On 18 januari John Smith suggest to download the LV8.5 NXT toolkit patch, to solve the 1003 invoke node error.
 
Can anyone tell me where i can find/download this patch?
 
Thanx for your time, Jos
Member JS
Member
JS
Posts: 69
0 Kudos

Re: LabVIEW 8.5 NXT toolkit patch?



janus wrote:
On 18 januari John Smith suggest to download the LV8.5 NXT toolkit patch, to solve the 1003 invoke node error.
 
Can anyone tell me where i can find/download this patch?
 
Thanx for your time, Jos


Hi janus,

You can download the patch from
http://zone.ni.com/devzone/cda/tut/p/id/4435

Go to the "download the toolkit now" link and one of the options in that page will be to get the update.  Please make sure you read the release notes and mass-compile the directories indicated.

Joel Sumner
NI-Shanghai
Member
Lars R
Posts: 2
0 Kudos

Re: LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

hi...

 

i make a VI, using the ultrasonic sensor and the movement of the motor, connecting the distance output of the us sensor to the power of the motor, the VI works well in the nxt, but when i compiled the vi, it tooks at least 15 minutes...and this warning appears:

The shared library expected to be at "NXTInputOutput.dll" was loaded from "C:\Archivos de programa\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit\shared\NXTInputOutput\NXTInputOutput.dll".

its normal that the compile process last that long?

 

thanks

Member JS
Member
JS
Posts: 69
0 Kudos

Re: LabVIEW Toolkit for LEGO MINDSTORMS NXT bugs

blockquote>
Lars R wrote:

h...but when i compiled the vi, it tooks at least 15 minutes...and this warning appears:


The shared library expected to be at "NXTInputOutput.dll" was loaded from "C:\Archivos de programa\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit\shared\NXTInputOutput\NXTInputOutput.dll".


its normal that the compile process last that long?







No, that's not normal. Did you mass-compile the toolkit as mentioned in the release notes? That's the typical reason for long compiles. I suspect your compile should only have taken 20 seconds or less
Joel Sumner
NI-Shanghai