NI Home > Community > NI Discussion Forums

LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Reply
Member
Kyle-H
Posts: 174
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

[ Edited ]

Sbolanos,

 

It will ask for where the installation originally occured from so you much have installed from the disc. So you need to place the install disc back into the cd drive. If you don't have the disk, then you just need to download the installer from our website for signal express. If you install via a download it keeps on the installation files in a directory on the computer so you can repair without the install disc.

 

You can download LabVIEW SignalExpress 2010 from ni.com/src.

Kyle Hartley
Applications Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

That's why I did. The installation was made from the disk, so I inserted the disk back on the DVD drive; you can see in Image 2 in the doc document that the National Instruments disk is installed in the D: drive, and anyway it should located it if I manually telling it where to find it.

 

Samuel

 

 

Member
Kyle-H
Posts: 174
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

sbolanos,

 

It looks like you're using the circuit design suite disc and not a signal express disc. Signal express isn't on the circuit design suite discs, there should be a seperate disc for signal express. If you don't have the disc. Just use the link from above to redownload the installer and you can either rerun the installer or point the repair to the installer files. 

Kyle Hartley
Applications Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

I'm using the Circuit Design Suite Disk because LabVIEW it is and installs from there. This is the disk I'm pointing to to repair the VISA Server. The only other separate disk that came with the Suite is the drivers disk.

 

I'm attaching a file with images of an expanded view of the Circuit Design Suite folder-tree in the disk, and you can see that there is a LV_SE folder that contains the installation files for LabVIEW Signal Express, even there is a Readme.html file that talks about the requirements, installation, activiation, etc of LabVIEW Signal Express, so it is there.

 

I also followed your advice about downloading LabVIEW Signal Express from the National Instruments website. I found version 2011 (all this time I've been using version 2010) and I installed it (the 2010 version was uninstalled first) but it doesn't work, it also crashes. I removed the NIVISV32.dll from the C:\Windows\System32 folder and did a VISA Server repair; this time the repair process finds the folder where the LabVIEW 2011 files were stored after expanding the downloaded file and it runs, but the NIVISV32.dll file is not regenerated by this process and LabVIEW Signal Express continues crashing. I've also included images of this problem in the attached file.

 

After installing LabVIEW Signal Express version 2011, the LEGO Mindstorms program still crashes.

 

Samuel

 

 

Member
Kyle-H
Posts: 174
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Samuel,

 

Could see see if there are multiple visa32.dll on the computer?

 

They should only be in the System32 folder and possibly in RT Images folder inside the NI folder in Program Files. 

Make sure the visa32.dll is published by NI. 

 

Lets try uninstalling NI visa, I found another issues where the customer resolved the error by reinstalling the visa drivers. 

Let me know how it goes. 

 

Kyle Hartley
Applications Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Hello.

 

I have the following information. I did a clean install of Windows 7 64 bits a proceeded to do the testing of the programs. First I installed the National Instruments software (Multisim, Ultiboard and LabView Signal Express), then I installed the Lego Mindstorms Software and this one worked.

 

Another test I did was uninstalling the Lego software and installing first the Tektronix OpenChoice software; the Tektronix software installs what they call TekVISA and after this installation I installed the Lego software but this time didn’t work.

 

In the attached file you can see images of the installation process of the Tektronix software; at some points (see Image 1) it asks for replacing or preserving the National Instruments VISA files, and our answer has always been to preserve the National Instruments VISA files, but also later notifies that some National Instruments files need to be update and there is no way of avoiding the updating (see Image 2). After the installation of the Tektronix software more VISA.dll files are in the system (see Images 3 and 4).

 

The initial VISA32.dll files found in the system after the installation of the National Instruments software are VISA32.dll and VISA64.dll both in the \windows\system32 folder and both from the IVI Foundation. When the Tektronix software is installed more VISA.dll files appear in the windows\sysWOW64 folder (VISA32.dll, VISA32.Tektronix.dll, VISA32.dll.old) and in the VXIpnp\WINNT\Tekvisa\Bin folder (VISA32.dll, signed by Tektonix).

 

If the Tektronix software is uninstalled and the Lego software is installed, then the Lego software doesn’t work. The only way of repairing this situation by uninstalling software is to completely uninstall the National Instruments and the Tektronix software and installing everything again, with the Lego software in first or second place to the National Instruments software but before the Tektronix software.

 

If with this information you see another way of solving the problem please let me know.

 

Thank you

 

Samuel

Active Participant
REDS
Posts: 263
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Hi sbolanos,

 

The TekVISA is most likely the cause of the issue. You would only want to have one VISA installed at a time, as you can see from this KB. To further reinforce the previous point, on this Tektronix thread you can see that having both versions of VISA will give you several issues. The recommendations of a user were not to use TekVISA if you have NI Hardware or Software and/or you are using a 64 bit OS (which you are). This FAQ also supports the previous statement.

Regards,
Daniel REDS
Applications Engineer

Help us grow.
If a post solves your question, mark it as The Solution.
If a post helps, give Kudos to it.
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Thank you.

 

After the test done it became clear that the problem was related to TekVISA; we will stop using it and we will follow the recommendation of getting rid of everything VISA related and start from scratch to avoid further problems.

 

Samuel