NI Home > Community > NI Discussion Forums

LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Do you mean 
Reply
Member
sbolanos
Posts: 10
0 Kudos
Accepted Solution

LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

When NI Circuit Design Suite Education Edition is installed first in a computer and the LEGO Mindstorms software second, the LEGO Mindstorms software doesn't work, it reports the following:

 

 

 

Error: A required file is broken

 

Possible Solutions: Reinstall the LEGO Mindstorms NXT Driver  (tried but doesn't work)

 

Error code: 1003

 

  

Ordinal not found

 

The ordinal 18 could not be located in the dynamic link library NIVISV32.dll

 

 

 

Error loading "fantom.dll"

 

The operating system can not run %1

 

 

 

On other computers the LEGO software starts running, it displays part of the initial screen and then a small window opens saying that the Mindstorms software has has an error and that it will close. The previous report doesn't show.

  

If LabView Signal Express is uninstalled and then the LEGO software reinstalled, the LEGO software works.

  

I've dowloaded and installed new and old versions of the NIVISV32.dll and this doesn't correct the problem. I went as far as version 4.20 of the dll because it is dated in 2007 and the dll file installed by the LEGO software when it works is also dated 2007, but if I install the dll without uninstalling LabView Signal Express, the LEGO software continues not working.

  

Please advice how to correct this problem without having to uninstall LabView Signal Express first. If the LEGO software is installed first, is LabView Signal Express going to use and not to replace the old 2007 version of the dll installed by the LEGO software? Is there any LEGO software update that corrects this problem?

 

I repeat: I know a solution is to uninstall LabView Signal Express, install LEGO Mindstorms and then reinstall LabView Signal Express but I have 60 computers already cloned and deployed with this problem, so I don't want to go to this long process to fix the problem. The computers are using Windows 7 and problems happen on both the 32 and 64 bits versions of Windows 7.

 

Any ideas???

Active Participant
Kyle-H
Posts: 205
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Sbolanos,

 

Let me try to reproduce the issue on one of our computers here. I will get back to you once I get everything installed. If I can reproduce it I'll see if I can find a quick work around. 

 

What is your expected timeframe, do you have any deadlines that these need to bet set up by. The quickest solution may be to reimage with what you have, since you did say that you have a working solution after reinstalling the mindstorms software and signal express. 

 

Kyle Hartley
RIO Product Support Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Thank you for the effort you'll put into this.

 

My time frame is one month and a half. Reimaging is an option but in my case implies the intervention of our IT Department (this is an Academic Institution and I'm on the academic side of it) for renaming computers, joining them to the domain, configuring remote administration software, etc. There is a lot of work before and after the cloning that I’d prefer to avoid and instead I’d like to implement a real solution.

 

I didn’t mention this in my initial post but in a classroom we used the LEGO Mindstorm software last summer without any problems, two weeks ago when we decided to start testing the computers the LEGO software failed to start on all the 25 computers in the classroom, it just crashed and generated a message informing it couldn’t continue running and that was it, no error code, no nothing; the image that we used is the same that we used last summer, except software and operating system updates but nothing involving LEGO or National Instruments software.  I don’t have an idea of what could’ve happened. Just in case this could be important: our computers are protected by Deep Freeze and it is only disabled for updating purposes.

Active Participant
Kyle-H
Posts: 205
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Sbolanos,

 

So I just got done installing the software. 

 

I installed it in this order, 

NI Circuit Design Suite Education Edition, entered serial #, restart later

Installed signal express 2011, entered serial #, restart later

Installed Lego Mindstorms NXT 2.0 software, restarted

 

Run Lego Mindstorms software and did not receive the error. 

 

I'll look into a little more into the and see if the error did present itself to someone else.

Kyle Hartley
RIO Product Support Engineer
National Instruments
Active Participant
Kyle-H
Posts: 205
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Sbolanos,

 

I was unable to locate any other similar issues. In my last post I included my install steps are these the same you followed? This was on a Windows 7 x86 virtual machine with no other software installed. Could you retry your installation on a fresh computer following my steps and see if the error does come up again? 

 

Kyle Hartley
RIO Product Support Engineer
National Instruments
Active Participant
Kyle-H
Posts: 205
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Sbolanos,

 

I was unable to locate any other similar issues. In my last post I included my install steps are these the same you followed? This was on a Windows 7 x86 virtual machine with no other software installed. Could you retry your installation on a fresh computer following my steps and see if the error does come up again? 

 

Kyle Hartley
RIO Product Support Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

I couldn't reproduce the error either, but in our x86 computers this problem appeared after several months; we used LEGO Mindstorms last time in Summer 2011 without any problems and just three weeks ago when we were checking the computer for our Summer 2012 classes if when we noticed the problem. I’m still going to try to reproduce the error in an x64 computer where the problem appeared immediately.

Anyway, I’m attaching a word file with images of captured screens where you can see the error reports generated by LEGO Mindstorms and a series of steps uninstalling and reinstalling these program plus LabVIEW, until LEGO Mindstorms finally works after having uninstalled all traces of LabVIEW.

Images can be expanded and zoomed in to a better view of the details and if I can reproduce the problem in an x64 computer I’ll let you know.

Please see if you can find out something based on the images I’m sending.

 

Thank you.

Active Participant
Kyle-H
Posts: 205
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

[ Edited ]

Sbolanos,

 

Alright I think I found some more info on NIVISV32.dll. It relates to visa. The error either has to do with a visa server and a visa runtime engine mismatch (different version #s), multiple copies of the NIVISV32.dll on the system, or a corrupt file. Try performing a search for the NIVISV32.dll on one of the affected computers. You can then delete them and perform a repair of the VISA server from the add/remove programs window. 

 

VISA Downloads to update if there is a version mismatch

http://search.ni.com/nisearch/app/main/p/bot/no/ap/tech/lang/en/pg/1/sn/catnav:du,n8:3.1637,ssnav:su...

 

I can only assume the fantom.dll has to do with the fantom driver so possibly reinstalling that driver may fix the issue.

 

Kyle Hartley
RIO Product Support Engineer
National Instruments
Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

In my first post I mentioned the installation of several versions, new and old, of NIVISV32.dll trying to correct the problem and it didn't work, but I didn't perform a repair of the VISA server after installation, so I'll try that.

 

The reinstallation of the fantom.dll has also been done repeatedly and the problem persists.

 

Samuel

Member
sbolanos
Posts: 10
0 Kudos

Re: LEGO Mindstorms 2.0 crashes at startup when LabView Signal Express is installed first

Another problem…

 

I deleted NIVISV32.dll that I found in \Windows\System32 folder and then tried to repair the VISA Server; the repair process opens a window that ask to select the distribution; I select NI LabVIEW Signal Express 2010 and the window asks now for disk D:\Distributions\LV_SE, I insert the disk, click ok but the program responds saying that is not a valid distribution location. Tried this manually using the ellipsis button and the result is the same.

 

I’m attaching screen captures of the process where you can see the disk is in the D drive. Please tell me now how to repair the VISA Server.

 

Thank you

 

Samuel