LabVIEW Web UI Builder and Data Dashboard

Showing results for 
Search instead for 
Did you mean: 
Reply

I can't use "Import Web Service".

Re: I can't use "Import Web Service".

[ Edited ]

I've done this before.

I think I don't understand the process.

So correct me if I'm wrong:

1. Make some application in labview

2.Make Application Web Server

3.Deploy Web Wervice to Web Server which I can't

and finally 4. put this for example "http://localhost:82/WebService/add/5/8" in adress bar

 

Is it right or I'm missing something ?

 

Screenshot in attachment

 

0 Kudos
Message 11 of 18 (2,401 Views)
Reply
0 Kudos

Re: I can't use "Import Web Service".

domagoj,

 

The default port number for the Application Web Server is 8080.  Try using http://localhost:8080/WebService/add .

0 Kudos
Message 12 of 18 (2,383 Views)
Reply
0 Kudos

Re: I can't use "Import Web Service".

I tried but that doesn't work.

0 Kudos
Message 13 of 18 (2,378 Views)
Reply
0 Kudos

Re: I can't use "Import Web Service".

untitled.JPG

 

 

I made this right or is something wrong ?

I don't understand the whole process.

Please, if you have some time and will can you explain it to me ?

0 Kudos
Message 14 of 18 (2,372 Views)
Reply
0 Kudos

Re: I can't use "Import Web Service".

Your screenshot looks correct. After doing that I got a dialog that says to restart the PC after making that change, so be sure to do that if you haven't.

 

Basically the normal process is:

- Turn on the application web server for LabVIEW. From your last screenshot it looks like you've done this. If so, if you type http://localhost:8080 into your browser address bar, you should see a page. in LV2009 this is an intro page for the LabVIEW server. In LV2010 you'll just see "Access Error: 404 -- Not Found". If you can't get either of those, nothing after this will work.

- Create a web service in LabVIEW 2009 or 2010

- Build the web service

- Deploy the web service (Were you ever able to do this with no errors?)

- In LabVIEW Web UI Builder, use Import Web Service, and type "<your ip address>:8080" for Server URL. (You can also use 127.0.0.1:8080, but usually its better to use the machine's IP address. If you're trying localhost:8080, that may not work at all.)

 

Message 15 of 18 (2,367 Views)

Re: I can't use &quot;Import Web Service&quot;.

That is reply that I was waiting and searching.Smiley Very Happy

Thank you very much.

I have labview 2010 and it says in process "can't access error 404" or something like that.

I'll try through your instructions and I'll notify later if I suceed.

0 Kudos
Message 16 of 18 (2,345 Views)
Reply
0 Kudos

Re: I can't use &quot;Import Web Service&quot;.

[ Edited ]

So, here is my problem.

When I'm making Application Web Server I check the Enabled box and I write the 8080 in port box.

I click Apply, but there's no message of restarting the PC.

I've restarted it, you sayed I have to, but problem is when I put in address bar "http://localhost:8080".

It shows this page.

 

And yes, I weren't and I'm not able to deploy the web service.

There on previous page in one of my posts is picture of trying to deploy the web service.

 

Thank you in advance !

0 Kudos
Message 17 of 18 (2,340 Views)
Reply
0 Kudos

Re: I can't use &quot;Import Web Service&quot;.

Thanks to all !

Everything works !

Well, not everything.

I can't deploy application to web.

I mean, I have to buy it.

Probably I won't need this program in near future so no need for buying it.

 

Once more THANKS TO ALL !Smiley Happy

 

0 Kudos
Message 18 of 18 (2,271 Views)
Reply
0 Kudos