NI Home > Community > NI Discussion Forums

LabVIEW Real-Time Idea Exchange

Showing results for 
Search instead for 
Do you mean 
Announcements
The NI Idea Exchange is a product feedback forum where NI R&D and users work together to submit ideas, collaborate on their development, and vote for the ones they like best. View all of the NI Idea Exchanges to post an idea or add your opinion on an existing one today!
SFK

Allow selection of ethernet port for RT target discovery/deployment

Status: Completed
by Active Participant SFK on ‎02-25-2011 05:03 AM

Many developers have the primary ethernet port of their development computer reserved for the corporate intranet/internet access.

Unfortunately, MAX and other tools like RT System Deployment Utility expect the targets to be connected to the same primary port for initial configuration, because they do not allow the specification of a local IP on which to exchange the UDP configuration packets.

Being able to select the ethernet port on which the RT system is connected, e.g. through a ring control populated with all available NICs and their local IPs, would facilitate devolopment enormously in such constellations, because the developer would not need to switch cables and IP configurations every time he needs to reconfigure the RT system.

 

Thanks,

Sebastian

Status: Completed

Hi Everyone,

 

With the new NI Linux Real-Time based controllers released at NIWeek this year we include a USB Device port, which I think addresses the pain described in this post, allowing you debug/modify the target without messing with your existing Ethernet infrastructure. For more information you can read here: Ethernet over USB Connection for Simplified Target Configuration, Debugging, and Maintenance

 

Best Regards,

Deborah Y.

LabVIEW Real-Time Product Manager

 

 

Comments
by Member Mr B. on ‎02-25-2011 05:31 AM

That feature would have saved me a lot of time in the past when I was unsuccessfully trying to detect unconfigured RT targets with MAX on some machines.

by Member dwisti ‎02-25-2011 09:23 AM - edited ‎02-25-2011 09:24 AM

Wow so many kudos in only 1 day.  I have my primary Ethernet port connected to my corporate intranet/internet access and my other static.  I use MAX and a RT system deployment utility every day and don't have any problems.  Can you please explain this problem in more detail?

by Active Participant SFK ‎02-25-2011 09:47 AM - edited ‎02-25-2011 09:49 AM

Hi dwisti,

once your RT system is configured, everything works fine even if it is connected to a secondary NIC. The trouble only starts with new or reset systems on 0.0.0.0, see e.g. http://digital.ni.com/public.nsf/allkb/E50CB56DBDA192E08625769B0074B09A?OpenDocument or http://digital.ni.com/public.nsf/allkb/471DB0C8F58725ED8625763B00677921?OpenDocument for similar effects with other systems...

 

Best regards,

Sebastian

 

by Member dwisti on ‎02-25-2011 09:54 AM

I don't have any trouble with new or reset systems on 0.0.0.0.  I can see the remote system on either subnet with MAX and set the IP address without any problems.  I've been using RT since Labview 8.5 and this has never been an issue on all the machines and laptops I've used.  Could this be a new problem?  What version of MAX are you using?

by Member Daniel Zens on ‎03-02-2011 05:45 AM

Hello,

 

the problem occurs since Windows 7. UDP commands are transmitted to the default network adapter only. If the second network adapter is connected to an unconfigured RT target, the MAX is not able to find the RT target because of not UDP response. It is the same problem in the RT System Deployment Utility.

 

Best regards,

Daniel

by Member dwisti on ‎03-02-2011 08:06 AM

I'm using Windows 7 and still no problems here.  I don't want to sound like a stick in the mud here against new ideas but I truly do not have this problem.  What are the specific steps or setup used to cause this problem?  I can't seem to put my system in a situation were I can't see or change the IP address of my RT targets.  What does it mean by default network adapter?  How can I set a default network adapter?  If 26 people already kudo'ed the idea then many people must have this problem.  How is your system setup when your having problems?

by Active Participant JoshuaP on ‎03-02-2011 09:06 AM

It looks like this issue was fixed in MAX 4.5 back in 2008.

 

http://digital.ni.com/public.nsf/allkb/4DA2BCEF4200FF1B862573A600741AF9

by Member Daniel Zens on ‎03-03-2011 02:31 AM

Hello,

 

the problem still occurs in MAX 4.7 32bit with Windows7 64bit.

 

If two network adapters are mounted e.g. 1st ip: 172.40.80.173; 2nd: 192.168.0.1 (connected to RT) Windows 7 has a default communication order. This order can be set in the advanced network settings (only admin). Is the network adapter connected to RT not the 1st one, all UDP broadcasts commands are transmitted to the wrong network, because UDP still use the default network adapter if no one is specified. See LabVIEW help: http://zone.ni.com/reference/en-XX/help/371361G-01/lvcomm/udp_open/ net address: This function broadcasts only on the default network address.

 

Best regards,

Daniel

by Active Participant JoshuaP on ‎03-03-2011 08:17 AM

Yes, but MAX is not written using these VI's.  It actually enumerates every network adapter and performs the query on each port.  So, MAX it self should not have this limitation. 

by Member NISTGas on ‎01-09-2012 09:46 AM

Was this issue ever resolved?  I am having the same problem on my Wndows 7 development system.  I have two network cards, one for the corporate network, and the other connected to my sbRIO.  I tried all permeations of setup and all failed to see the card.  I tried disabling the primary card and connecting the rio to the secondary, no luck; disabling the secondary card connecting the Rio to the primary card, no luck; disabling the firewall (both while connected to primary and secondary), no luck; Also tried under my domain login and also in my local login, no luck.  I had to connect it to an old XP system to get the IP set.  WHat is blocking the 0.0.0.0 address on WIndows 7?

 

Regards,

Frank

About LabVIEW Real-Time Idea Exchange

Have a LabVIEW Real-Time Idea?

  1. Does your idea apply to LabVIEW in general? Get the best feedback by posting it on the original LabVIEW Idea Exchange.
  2. Browse by label or search in the LabVIEW Real-Time Idea Exchange to see if your idea has previously been submitted. If your idea exists be sure to vote for the idea by giving it kudos to indicate your approval!
  3. If your idea has not been submitted click New Idea to submit a product idea to the LabVIEW Real-Time Idea Exchange. Be sure to submit a separate post for each idea.
  4. Watch as the community gives your idea kudos and adds their input.
  5. As NI R&D considers the idea, they will change the idea status.
  6. Give kudos to other ideas that you would like to see in a future version of LabVIEW Real-Time!
Idea Statuses
Top Kudoed Authors